Bug 164533 - python-ldap: Request for version upgrade
python-ldap: Request for version upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-ldap (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
http://cvs.sourceforge.net/viewcvs.py...
RHEL4U3NAK
: Desktop, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 11:41 EDT by Matt Hyclak
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 18:27:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated python-ldap spec file (2.84 KB, text/plain)
2005-08-04 11:36 EDT, Matt Hyclak
no flags Details

  None (edit)
Description Matt Hyclak 2005-07-28 11:41:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050722 Galeon/1.3.21

Description of problem:
There have been some fixes in the python-ldap code, especially for x86_64 systems. As such, I would like to request an update to version 2.0.9.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
New version available with some pretty big fixes/enhancements
  

Additional info:
Comment 1 Matt Hyclak 2005-08-04 11:36:08 EDT
Created attachment 117456 [details]
Updated python-ldap spec file
Comment 8 Sander Steffann 2006-01-07 16:06:11 EST
+1 for this request. Updating to 2.0.4 would be enough for me though. Between
2.0.1 and 2.0.4 there are almost only bugfixes and the code changes are minimal
(see the diffstat and the changelog below), and from looking at the code I can't
find anything that could cause a regression, so please include this in the next
RHEL4 update as early as possible.

Here is the diffstat:
diff -rub python-ldap-2.0.1 python-ldap-2.0.4 | diffstat
 CHANGES                |   45 ++++++++++++++++++++++++++++++++++-
 Demo/passwd_ext_op.py  |only
 Demo/sasl_bind.py      |    8 ++++++
 Lib/ldap/__init__.py   |    4 +--
 Lib/ldap/ldapobject.py |   11 +++++++-
 Modules/LDAPObject.c   |   63 ++++++++++++++++++++++++++++++++++++++++++-------
 Modules/common.h       |    4 +--
 Modules/constants.c    |   22 +++++++++++++++--
 Modules/ldapmodule.c   |    5 +--
 PKG-INFO               |    2 -
 setup.cfg              |    6 ++--
 setup.py               |    4 +--
 12 files changed, 147 insertions(+), 27 deletions(-)

----------------------------------------------------------------
Released 2.0.4 2004-10-27

Changes since 2.0.3:

Modules/
* Applied some fixes for 64-bit platforms to LDAPObject.c
* Constants ldap.TLS_AVAIL and ldap.SASL_AVAIL will indicate
  whether python-ldap was built with support for SSL/TLS
  and/or SASL

setup.py and Modules/
* Applied some fixes for building under Win32

----------------------------------------------------------------
Released 2.0.3 2004-10-06

Changes since 2.0.2:

* Added support for LDAP Password Modify Extended Operation
  (see RFC 3062)

Demo/:
* Added passwd_ext_op.py

Modules/
* Added l_ldap_passwd() in LDAPObject.c

Lib/
* Added methods passwd() and passwd_s() to
  ldap.ldapobject.LDAPObject

----------------------------------------------------------------
Released 2.0.2 2004-07-29

Changes since 2.0.1:

Modules/
* Fixed detecting appropriate OpenLDAP libs version for
  determining whether ldap_whoami_s() is available or not.
  This fixes build problems with OpenLDAP libs 2.1.0 up
  to 2.1.12.
Comment 10 Matthias Clasen 2006-10-12 15:54:00 EDT
The version currently in RHEL5 is 2.2.0
Comment 12 RHEL Product and Program Management 2006-12-22 18:27:54 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.