Bug 164561 - Help balloon links 404s
Help balloon links 404s
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ken Ganong
Max Spevack
:
: 163387 (view as bug list)
Depends On:
Blocks: 147875
  Show dependency treegraph
 
Reported: 2005-07-28 15:06 EDT by Ken Ganong
Modified: 2007-04-18 13:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 22:41:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2005-07-28 15:06:04 EDT
Description of problem:
Some of our help balloon links seem to be incorrect.  I've seen two in the last
couple days, User List, and User Details pages. 

We should verify the validaty of help balloon links before shipping our product.
Comment 1 Ken Ganong 2005-07-28 18:05:01 EDT
Here are the differences made in pxts

- help/channel-mgmt/sm-errata-mgmt-details.html
+ help/channel-mgmt/s1-sm-errata-mgmt-details.html

- help/channel-mgmt/custom-errata-mgmt.html
+ help/channel-mgmt/ch-custom-errata-mgmt.html

- help/channel-mgmt/custom-errata-mgmt.html#CUSTOM-ERRATA-MGMT-PAGE
+ help/channel-mgmt/ch-custom-errata-mgmt.html#S1-CUSTOM-ERRATA-MGMT-PAGE

- help/channel-mgmt/custom-channel-mgmt.html
+ help/channel-mgmt/ch-custom-channel-mgmt.html

- help/channel-mgmt/custom-channel-details.html
+ help/channel-mgmt/s1-custom-channel-details.html
Comment 2 Ken Ganong 2005-07-28 18:06:12 EDT
There are alot of these still in pxts, help-url=""
They aren't broken links, but I also wouldn't call them helpful.
Comment 3 Ken Ganong 2005-07-29 13:33:47 EDT
Here are the differences made in jsps

- help/provisioning/s1-sm-users.html#S2-SM-USER-LIST
+ help/reference/s1-sm-users.html#S2-SM-USER-LIST

- help/provisioning/s1-sm-your-rhn.html
+ help/reference/s1-sm-your-rhn.html

- help/channel-mgmt/sm-errata-mgmt-details.html
+ help/channel-mgmt/s1-sm-errata-mgmt-details.html

- help/channel-mgmt/custom-errata-mgmt.html
+ help/channel-mgmt/ch-custom-errata-mgmt.html

- help/channel-mgmt/custom-errata-mgmt.html#CUSTOM-ERRATA-MGMT-PAGE
+ help/channel-mgmt/ch-custom-errata-mgmt.html#S1-CUSTOM-ERRATA-MGMT-PAGE
Comment 4 Ken Ganong 2005-07-29 13:40:53 EDT
Test Plan:
Click lots of help balloon links which appear near the header of many of our
pages.  Verify that you do not get a 404 and that the information presented is
relevant to the page you were on.  Most of the problems were seen on users
pages, errata management pages, and scheduled action pages.

Important note:  There seems to be a bug with firefox so that some of the
anchors (the stuff after the #) don't work correctly on the first visitation of
a page.  Hitting the refresh button should bring you to the correct place on the
page.  If it doesn't, this bug fails.  If it does, its firefox's fault.
Comment 5 Michael Bowman 2005-07-29 14:40:45 EDT
*** Bug 163387 has been marked as a duplicate of this bug. ***
Comment 6 Mike McCune 2005-08-05 13:42:51 EDT
will qa this.
Comment 7 Max Spevack 2005-08-07 15:16:40 EDT
I clicked a decent number of help balloons, and didn't get any 404 errors. 
Moving to PROD_READY, if others are found, they can be opened.

Note You need to log in before you can comment on or make changes to this bug.