Bug 164565 - Firstboot error during the reconfiguration process
Firstboot error during the reconfiguration process
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 15:21 EDT by Armel Kermorvant
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 10:43:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armel Kermorvant 2005-07-28 15:21:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Error during the boot with firstboot software, see the trace below :

traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 506, in loadModules
    vbox, pix, title = module.launch()
  File "/usr/src/build/548976-i386/install/usr/share/firstboot/modules/boot_gui.py", line 177, in launch
    return FirstbootGuiWindow.launch(self)
  File "/usr/lib/python2.4/site-packages/rhpl/firstboot_gui_window.py", line 106, in launch
    internalVBox.pack_start(self.myVbox, True)
AttributeError: BootWindow instance has no attribute 'myVbox'

The message doesn't appear if I don't use the reconfigSys (Basic Configuration)

Version-Release number of selected component (if applicable):
firstboot-1.3.42-1.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
all commands below is in root mode

1. remove the fistboot file into /etc/sysconfig/
2. create an empty file with this name reconfigSys in /etc
3. I create a link into /etc/rc3.d and /etc/rc5.d with this command :
ln /etc/init.d/firstboot /etc/rc3.d/S95firstboot
ln /etc/init.d/firstboot /etc/rc5.d/S95firstboot
4. reboot the system
5. on the screen the error message appear on the black screen after the progression task :

traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 506, in loadModules
    vbox, pix, title = module.launch()
  File "/usr/src/build/548976-i386/install/usr/share/firstboot/modules/boot_gui.py", line 177, in launch
    return FirstbootGuiWindow.launch(self)
  File "/usr/lib/python2.4/site-packages/rhpl/firstboot_gui_window.py", line 106, in launch
    internalVBox.pack_start(self.myVbox, True)
AttributeError: BootWindow instance has no attribute 'myVbox'

I clic on the button and the software is launched and I choose my language ....
The software works

  

Actual Results:  All time the error appear.
I prepare some PC with FC 4 for the customers and I finish all configuration by this, because the customer accept the license, create the password for root and finish the configuration (User, Screen Resolution ....)



Expected Results:  I waiting a workaround for the 1st time and after a fix.

Additional info:

Language : French

Thanks for your support

Best regards

Armelk
Comment 1 Chris Lumens 2005-10-11 13:50:13 EDT
I am unable to reproduce this with Rawhide.  In addition, rhpl and firstboot
have undergone a major reconstruction so I might have fixed this problem during
that work.  Please test against an FC5 test when released and let me know if you
are still seeing it.
Comment 2 Armel Kermorvant 2005-10-12 04:12:30 EDT
Good Morning,

I'm waiting FC5 Test for evaluation.
On this software, is it possible I choose some screen during the fist boot.
I explain this :
I need to choose Time Zone, Resolution and other screen, but I don't need the
Root creation and User creation account

Thanks for your feedback and have a nice day

Armelk
Comment 3 Chris Lumens 2005-12-02 14:00:59 EST
No, you have to step through all the screens.  Is this now working better with
test1?
Comment 4 Armel Kermorvant 2005-12-02 14:29:39 EST
Good Afternoon,

I plan next week the 1st evaluation of FC5 Test 1.
I expext to come back with the feedback monday.

Have a nice week end

Armel
Comment 5 Chris Lumens 2006-02-06 11:23:04 EST
Is this better in FC5T2?
Comment 6 Chris Lumens 2006-03-10 10:43:08 EST
Feel free to reopen this bug if you are still seeing problems in FC5.

Note You need to log in before you can comment on or make changes to this bug.