Bug 164678 - failed to start since update to 0.7.9
failed to start since update to 0.7.9
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: seahorse (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 18:29 EDT by Stephan Sachse
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 13:47:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -o seahorse (89.34 KB, text/plain)
2005-07-30 18:25 EDT, Stephan Sachse
no flags Details

  None (edit)
Description Stephan Sachse 2005-07-29 18:29:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
since update to 0.9.2-1.fc4 i cant start seahorse

Version-Release number of selected component (if applicable):
seahorse-0.7.9-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. type "seahorse" in terminal
  

Actual Results:  $ seahorse
** Message: init gpgme version 1.0.2

(seahorse:3892): Gtk-WARNING **: Remote: missing action

(seahorse:3892): Gtk-WARNING **: remote-find: missing action

(seahorse:3892): Gtk-WARNING **: remote-sync: missing action

(seahorse:3892): Gtk-CRITICAL **: find_menu_position: assertion `GTK_IS_WIDGET (prev_child)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_menu_item_get_submenu: assertion `GTK_IS_MENU_ITEM (menu_item)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_menu_shell_insert: assertion `GTK_IS_MENU_SHELL (menu_shell)' failed

(seahorse:3892): Gtk-CRITICAL **: find_menu_position: assertion `GTK_IS_MENU_SHELL (menushell)' failed

(seahorse:3892): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(seahorse:3892): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(seahorse:3892): Gtk-CRITICAL **: find_menu_position: assertion `GTK_IS_WIDGET (prev_child)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_menu_item_get_submenu: assertion `GTK_IS_MENU_ITEM (menu_item)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)' failed

(seahorse:3892): Gtk-CRITICAL **: gtk_menu_shell_insert: assertion `GTK_IS_MENU_SHELL (menu_shell)' failed

(seahorse:3892): Gtk-CRITICAL **: find_menu_position: assertion `GTK_IS_MENU_SHELL (menushell)' failed

(seahorse:3892): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(seahorse:3892): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(seahorse:3892): Gtk-WARNING **: remote-find: missing action

(seahorse:3892): Gtk-WARNING **: remote-sync: missing action

(seahorse:3892): Gtk-CRITICAL **: find_menu_position: assertion `GTK_IS_WIDGET (prev_child)' failed

(seahorse:3892): Gtk-CRITICAL **: find_menu_position: assertion `GTK_IS_WIDGET (prev_child)' failed

(seahorse:3892): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(seahorse:3892): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

Additional info:
Comment 1 Seth Vidal 2005-07-30 10:11:00 EDT
what program was 0.9.2 you were referring to before?

do any other gtk programs work?

run gedit and tell me if that works, too.

Thanks
Comment 2 Stephan Sachse 2005-07-30 13:36:59 EDT
(In reply to comment #1)
> what program was 0.9.2 you were referring to before?

seahorse is at version 0.7.9-1.fc4, before is was seahorse-0.7.7-3

> do any other gtk programs work?

i have only gtk programs here, and all works fine

> run gedit and tell me if that works, too.

running gedit from a terminal works w/o any output or errors

thanks for investigate
Comment 3 Seth Vidal 2005-07-30 14:10:51 EDT
In the initial report you said:

Description of problem:
since update to 0.9.2-1.fc4 i cant start seahorse


where were you getting that version string from?

Comment 4 Stephan Sachse 2005-07-30 14:58:34 EDT
(In reply to comment #3)
> In the initial report you said:
> 
> Description of problem:
> since update to 0.9.2-1.fc4 i cant start seahorse

yes sorry this was a typo by me :( sorry for this

> where were you getting that version string from?

*hmm* good question i have no idea, i type this by hand :p

but Version-Release number was correct ;)

> Version-Release number of selected component (if applicable):
> seahorse-0.7.9-1.fc4
Comment 5 Seth Vidal 2005-07-30 15:04:33 EDT
okay  - please run:

strace -o /tmp/seahorse.debug seahorse

and attach the file /tmp/seahorse, please.
Comment 6 Michael Schwendt 2005-07-30 15:31:54 EDT
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208825376 (LWP 2565)]
0x03614d92 in gtk_ui_manager_get_action () from /usr/lib/libgtk-x11-2.0.so.0
(gdb) bt
#0  0x03614d92 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#1  0x03614320 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#2  0x03614320 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#3  0x03615273 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#4  0x004625fd in seahorse_widget_show ()
   from /usr/lib/libseahorse-internal.so.0
#5  0x08056165 in seahorse_key_manager_show ()
#6  0x0804fbbd in main ()
Comment 7 Seth Vidal 2005-07-30 15:35:35 EDT
run these commands and report the results please:

rpm -V gtk2
rpm -V glib2

also run:
yum install seahorse-debuginfo

thanks
Comment 8 Michael Schwendt 2005-07-30 16:55:45 EDT
Up-to-date FC4, clean installation. I don't think I've run seahorse in this
account before.

$ rpm -V gtk2 glib2 seahorse
$

$ rpm -q seahorse seahorse-debuginfo gtk2 glib2
seahorse-0.7.9-1.fc4
seahorse-debuginfo-0.7.9-1.fc4
gtk2-2.6.7-4
glib2-2.6.4-1

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209112096 (LWP 7187)]
0x03614d92 in gtk_ui_manager_get_action () from /usr/lib/libgtk-x11-2.0.so.0
(gdb) bt
#0  0x03614d92 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#1  0x03614320 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#2  0x03614320 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#3  0x03615273 in gtk_ui_manager_get_action ()
   from /usr/lib/libgtk-x11-2.0.so.0
#4  0x003e55fd in seahorse_widget_show (swidget=0x9aa5198)
    at seahorse-widget.c:343
#5  0x08056165 in seahorse_key_manager_show (sctx=0x9a96618)
    at seahorse-key-manager.c:745
#6  0x0804fbbd in main (argc=-1209112096, argv=0xb7ee69e0) at main.c:478
Comment 9 Seth Vidal 2005-07-30 18:21:39 EDT
okay I've found a machine I can replicate this on. So I'm going to try to solve
it there.

Thanks
Comment 10 Stephan Sachse 2005-07-30 18:25:04 EDT
Created attachment 117315 [details]
strace -o seahorse

# rpm -V gtk2 glib2 seahorse
# rpm -q seahorse seahorse-debuginfo gtk2 glib2
seahorse-0.7.9-1.fc4
seahorse-debuginfo-0.7.9-1.fc4
gtk2-2.6.7-4
glib2-2.6.4-1
Comment 11 Stephan Sachse 2005-07-30 18:28:37 EDT
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208731168 (LWP 4049)]
0x435a3d92 in gtk_ui_manager_get_action () from /usr/lib/libgtk-x11-2.0.so.0
(gdb)
(gdb)
(gdb)
(gdb) bt full
#0  0x435a3d92 in gtk_ui_manager_get_action () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#1  0x435a3320 in gtk_ui_manager_get_action () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#2  0x435a3320 in gtk_ui_manager_get_action () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#3  0x435a4273 in gtk_ui_manager_get_action () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#4  0x41cba5fd in seahorse_widget_show (swidget=0x80aad60) at seahorse-widget.c:343
        widget = Variable "widget" is not available.
Comment 12 Seth Vidal 2005-08-04 01:11:54 EDT
Got it

looks like openldap-devel is a buildreq without being stated in the configure
scripts. I checked the fix into cvs just waiting on the buildsys to build a push
this.

once the build gets out I'll post here again and you can test the fix.
thanks
Comment 13 Seth Vidal 2005-08-04 01:40:36 EDT
see seahorse-0.7.9-2.fc4  coming to a fedora extras mirror shortly.
Comment 14 Seth Vidal 2005-08-04 02:07:15 EDT
<sigh> Sorry -2 doesn't fix it - but -3 should.

I typo'd something when I checked in the updated spec file so what worked for me
didn't work once it was in the buildsys.
Comment 15 Seth Vidal 2005-08-04 02:29:14 EDT
confirmed 0.7.9-3.fc4 fixes the problem

If you could try the rpm from here:
http://buildsys.fedoraproject.org/logs/4/392-seahorse-0.7.9-3.fc4/

or wait until it is signed and pushed to extras.

thanks
Comment 16 Stephan Sachse 2005-08-04 13:47:30 EDT
seahorse-0.7.9-3.fc4 works also for me

thanks for the fix

Note You need to log in before you can comment on or make changes to this bug.