Bug 164680 - Login failed when upgrade from FC4
Login failed when upgrade from FC4
Status: CLOSED DUPLICATE of bug 164418
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-29 18:53 EDT by Marie Henri Beyle
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 08:37:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marie Henri Beyle 2005-07-29 18:53:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
After an upgrade with yum from FC3 to FC4, some components don't work properly. There are many problems with software that depends on Berkeley Database db3. This software fails with db4 version of Berkeley. I have resolved all the problems but not one of them. And I don't know if the problem is the same (db4).
vsftpd failed when users login and display this error:

500 OOPS: priv_sock_get_result


Detailed login:

Connected to localhost.localdomain.
220 Welcome to LT FTP Service.
530 Please login with USER and PASS.
530 Please login with USER and PASS.
Name (localhost:userftp): userftp
331 Please specify the password.
Password: *******
500 OOPS: priv_sock_get_result
Login failed.
421 Service not available, remote server has closed connection


Because I have a Berkeley database with "shadow" users on it, I don't know if this problem is with Berkeley, with PAM, etc.

Version-Release number of selected component (if applicable):
vsftpd-2.0.3-1.FC3

How reproducible:
Always

Steps to Reproduce:
1. Connect vsftp
2. Type user and password
  

Actual Results:  vsftpd returns 500 OOPS: priv_sock_get_result .

Expected Results:  ftp login correctly ...

Additional info:

The problem begins when upgrade the system from FC3 to FC4 .
Comment 1 Radek Vokal 2005-08-03 02:20:14 EDT
May I have your vsftpd.conf file? Are you also using the recent version of PAM?
There are some changes in PAM and the new vsftpd requires modules from the
latest PAM version. 
Comment 2 Marie Henri Beyle 2005-08-06 06:52:36 EDT
I think the problem is with pam or db4. vsftpd fails when I use "ghost users" 
and write a special /etc/pam.d/vsftdp file for authenticate those users.

If I use this config pam vsftpd file (vsftpd.login is a Berkeley database):

auth required /lib/security/pam_userdb.so db=/etc/vsftpd/vsftpd.login
account required /lib/security/pam_userdb.so db=/etc/vsftpd/vsftpd.login

vsftpd login fails everytime (works fine on FC3)

But if I use original /etc/pam.d/vsftpd in Fedora, login works OK. I want to 
use a Berkeley database with "ghost users" because I nedd to create accounts 
only for ftp, without system account.


pam: pam-0.79-9.4

vsftpd.conf:
anonymous_enable=NO
local_enable=YES
write_enable=NO
local_umask=022
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
#chown_uploads=YES
#chown_username=whoever
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES
ftpd_banner=Welcome to LT FTP Service.
chroot_local_user=YES
guest_enable=YES
guest_username=virtual
#ls_recurse_enable=YES
user_config_dir=/etc/vsftpd/users
pam_service_name=vsftpd
userlist_enable=YES
#virtual_use_local_privs=YES
listen=YES
tcp_wrappers=YES
Comment 3 Tomas Mraz 2005-08-08 08:37:58 EDT

*** This bug has been marked as a duplicate of 164418 ***

Note You need to log in before you can comment on or make changes to this bug.