Bug 164724 - GtkDeprecationWarnings at startup on up2date FC4 installation
GtkDeprecationWarnings at startup on up2date FC4 installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-30 21:48 EDT by J. Erik Hemdal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 06:18:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J. Erik Hemdal 2005-07-30 21:48:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I receive the following to stderr when starting system-config-network:

 /usr/share/system-config-network/netconfpkg/gui/maindialog.py:963: GtkDeprecationWarning: gtk.timeout_remove is deprecated, use gobject.source_remove instead
  gtk.timeout_remove(self.tag)
/usr/share/system-config-network/netconfpkg/gui/GUI_functions.py:516: GtkDeprecationWarning: gtk.mainiteration is deprecated, use gtk.main_iteration instead
  gtk.mainiteration()

It appears to happen only on first startup.  Not serious, but definitely ugly.

Version-Release number of selected component (if applicable):
system-config-network-1.3.26-1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.Appears to happen only once at first startup. 

As root, issue system-config-network &
2.
3.
  

Actual Results:  These messages were dumped to my terminal window.

Expected Results:  Expected no warnings and simply the display of the window.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.