Bug 164728 - libpcap.so.0.9.1 is needed by package ethereal
Summary: libpcap.so.0.9.1 is needed by package ethereal
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcpdump
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-31 04:42 UTC by Peter Ennis
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-08-03 07:23:52 UTC


Attachments (Terms of Use)

Description Peter Ennis 2005-07-31 04:42:40 UTC
Description of problem:

Error: Missing Dependency: libpcap.so.0.9.1 is needed by package ethereal
Error: Missing Dependency: libpcap.so.0.9.1 is needed by package ppp

So I reread the Wiki TestingManifesto and tried:

yum --exclude=ethereal --exclude=ppp update

which results in:


--> Running transaction check
--> Processing Dependency: libpcap.so.0.8.3 for package: ethereal
--> Processing Dependency: libpcap.so.0.8.3 for package: ppp
--> Finished Dependency Resolution
Error: Missing Dependency: libpcap.so.0.8.3 is needed by package ethereal
Error: Missing Dependency: libpcap.so.0.8.3 is needed by package ppp
[root@lfs ~]#

No more help found in testing guidelines except "wait a few days
for new developer release". Waiting...

Search and google for "libpcap.so.0.9.1 is needed by package ethereal"
returned nothing.


Version-Release number of selected component (if applicable):


How reproducible:
yum update

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Seth Vidal 2005-07-31 06:36:35 UTC
try running:
yum --exclude=libpcap update

I'm betting this is just a temporary broken dep in rawhide and not a bug at all.


Comment 2 Peter Ennis 2005-08-01 00:40:09 UTC
Quoting from above:
No more help found in testing guidelines except "wait a few days
for new developer release". Waiting... == "not a bug at all"
??? TBD

Thanks for the pointer. The results of running:
yum --exclude=libpcap update
are below...

--> Running transaction check
--> Processing Dependency: libpcap.so.0.9.3 for package: isdn4k-utils
--> Processing Dependency: libpcap.so.0.9.1 for package: ppp
--> Processing Dependency: libpcap.so.0.9.1 for package: ethereal
--> Finished Dependency Resolution
Error: Missing Dependency: libpcap.so.0.9.3 is needed by package isdn4k-utils
Error: Missing Dependency: libpcap.so.0.9.1 is needed by package ethereal
Error: Missing Dependency: libpcap.so.0.9.1 is needed by package ppp
[root@lfs ~]#


Comment 3 Jeremy Katz 2005-08-01 12:36:30 UTC
This is due to the package not being rebuilt.

Comment 4 Radek Vokal 2005-08-03 07:23:52 UTC
ethereal got rebuilt against new libpcap.


Note You need to log in before you can comment on or make changes to this bug.