Bug 164734 - clamav in FC2 repo has fc1 disttag
clamav in FC2 repo has fc1 disttag
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-31 04:13 EDT by Kevin Kofler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 17:03:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2005-07-31 04:13:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; H010818)

Description of problem:
The clamav RPMs in the FC2 repository at fedora.us have "fc1" disttags. I haven't checked whether these are the wrong packages or whether they only have a wrong disttag, but either way something is messed up.

Version-Release number of selected component (if applicable):
clamav-0.86.2-2.fc1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
Just look at the disttag. ;-)

Actual Results:  There is an "fc1" disttag.

Expected Results:  There should be an "fc2" disttag.

Additional info:
Comment 1 Warren Togami 2005-07-31 05:47:52 EDT
My fault, I will fix this soon.
Comment 2 Warren Togami 2005-07-31 06:15:53 EDT
http://download.fedora.us/pending/fedora/2/i386/RPMS.stable/
Kevin, please help by verifying that the packages here work properly.
Comment 3 Kevin Kofler 2005-07-31 08:07:49 EDT
I fetched the updated clamav, clamav-data, clamav-lib and clamav-update RPMs 
from the pending URL you mentioned onto my FC2 system (they installed fine) and:
* ran freshclam. It told me to edit the example freshclam.conf. (This has 
changed between the very old clamav packages previously in FC2 and the new 
ones. Upstream decided that the default freshclam.conf is not good enough 
because you should select a mirror for your country rather than just using a 
random one. FC3/FC4 went through this change earlier.) I complied and did the 2-
line edit.
* ran freshclam again. Worked fine.
* ran clamscan on a known clean directory. Worked fine.
* ran clamscan on the EICAR antivirus test file. Detected the "virus" just fine.

I didn't test the milter because I don't have a mailserver running here (just a 
laptop still running FC2 because I didn't get around to updating it to a newer 
Fedora yet).
Comment 4 Kevin Kofler 2005-07-31 08:10:28 EDT
Actually, the freshclam.conf stuff was already in the previous update (0.85), I 
guess. I probably just hadn't run freshclam since then. ;-)
Comment 5 Kevin Kofler 2005-09-12 01:16:49 EDT
Why are these still pending? They fix the disttag issue in the released 
packages and I honestly can't see what they could break.
Comment 6 Kevin Kofler 2006-10-24 17:03:37 EDT
FC2 is discontinued even by Legacy now, so I don't expect this to get fixed 
anymore.

Note You need to log in before you can comment on or make changes to this bug.