Bug 164744 - Unable to edit users
Unable to edit users
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-31 08:06 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 10:16:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-07-31 08:06:28 EDT
Description of problem:
I am unable to edit any of the user accounts if I try via
Edit->Preferences->(click on a user)->Edit. Evolution just dies.

Version-Release number of selected component (if applicable):
2.3.6.1-2

How reproducible:
Always

Steps to Reproduce:
1. Click Edit->Preferences
2. Select an account
3. Click on edit
  
Actual results:
The following throwback is generated

Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1208813904 (LWP 8239)]
[New Thread -1327498320 (LWP 8297)]
[New Thread -1259344976 (LWP 8288)]
[New Thread -1248855120 (LWP 8287)]
[New Thread -1301304400 (LWP 8262)]
[New Thread -1290814544 (LWP 8254)]
[New Thread -1280324688 (LWP 8253)]
[New Thread -1269834832 (LWP 8252)]
[New Thread -1236493392 (LWP 8248)]
[New Thread -1226003536 (LWP 8247)]
0x00bc7402 in __kernel_vsyscall ()
#0  0x00bc7402 in __kernel_vsyscall ()
#1  0x00b9afcb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x078302ad in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  0x0805f5ba in segv_redirect (sig=11) at main.c:424
#4  <signal handler called>
#5  0x0114282d in emae_defaults_page (ec=0xae90c68, item=0x11d5ae8, 
    parent=0x0, old=0x0, data=0xa34be58) at em-account-editor.c:2144
#6  0x001868d7 in ec_rebuild (emp=0xae90c68) at e-config.c:568
#7  0x001875e2 in e_config_create_widget (emp=0xae90c68) at e-config.c:852
#8  0x00187716 in e_config_create_window (emp=0xae90c68, parent=0x0, 
    title=0xb7cffb16 "Account Editor") at e-config.c:897
#9  0x01143612 in em_account_editor_new (account=0x92061b8, 
    type=EMAE_NOTEBOOK, 
    id=0x11b10d0 "org.gnome.evolution.mail.config.accountEditor")
    at em-account-editor.c:2649
#10 0x01145607 in account_edit_clicked (button=0xac53140, user_data=0xac58040)
    at em-account-prefs.c:206
#11 0x003181a7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#12 0x0030b7ab in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#13 0x0031b29e in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#14 0x0031cbd8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#15 0x0031cf29 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#16 0x0049b957 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x0049d6b8 in gtk_button_get_alignment ()
   from /usr/lib/libgtk-x11-2.0.so.0
#18 0x003181a7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#19 0x0030b1b6 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#20 0x0030b7ab in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#21 0x0031aef3 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#22 0x0031cbd8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#23 0x0031cf29 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#24 0x0049b8d4 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x0049cbd5 in gtk_button_set_relief () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x00575182 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#27 0x0030b1b6 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#28 0x0030b7ab in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#29 0x0031b42a in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#30 0x0031c935 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#31 0x0031cf29 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#32 0x0066e7c9 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#33 0x0057230c in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#34 0x0057283d in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#35 0x002b4395 in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#36 0x0736ab7e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0x0736db86 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#38 0x0736de73 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#39 0x07483625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#40 0x0805fa36 in main (argc=1, argv=0xbff68144) at main.c:602

Thread 10 (Thread -1226003536 (LWP 8247)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9208f20) at e-msgport.c:511
	msg = 
Thread 9 (Thread -1236493392 (LWP 8248)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9208f20) at e-msgport.c:511
	msg = 
Thread 8 (Thread -1269834832 (LWP 8252)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9208f20) at e-msgport.c:511
	msg = 
Thread 7 (Thread -1280324688 (LWP 8253)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9208f20) at e-msgport.c:511
	msg = 
Thread 6 (Thread -1290814544 (LWP 8254)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9208f20) at e-msgport.c:511
	msg = 
Thread 5 (Thread -1301304400 (LWP 8262)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x920ba28) at e-msgport.c:511
	msg = 
Thread 4 (Thread -1248855120 (LWP 8287)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9208f20) at e-msgport.c:511
	msg = 
Thread 3 (Thread -1259344976 (LWP 8288)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9208f20) at e-msgport.c:511
	msg = 
Thread 2 (Thread -1327498320 (LWP 8297)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b977b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07a92117 in e_msgport_wait (mp=0x9205f00) at e-msgport.c:511
	msg = 
Thread 1 (Thread -1208813904 (LWP 8239)):
#0  0x00bc7402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00b9afcb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x078302ad in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x0805f5ba in segv_redirect (sig=11) at main.c:424
No locals.
#4  <signal handler called>
No symbol table info available.
#5  0x0114282d in emae_defaults_page (ec=0xae90c68, item=0x11d5ae8, 
    parent=0x0, old=0x0, data=0xa34be58) at em-account-editor.c:2144
	emae = 

Expected results:
I should be able to edit an account

Additional info:
Comment 1 Dave Malcolm 2005-08-09 16:02:49 EDT
Thanks for this report.

This works for me in 2.3.7, which should be available in tomorrow's rawhide. 
Please let me know if this fixes it for you.

Note You need to log in before you can comment on or make changes to this bug.