Bug 164840 - Enabling monitoring on a non-monitoring installed satellite
Enabling monitoring on a non-monitoring installed satellite
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
:
Depends On:
Blocks: 166621
  Show dependency treegraph
 
Reported: 2005-08-01 14:37 EDT by Ken Ganong
Modified: 2008-05-13 15:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 15:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Create Probe Traceback (9.43 KB, text/plain)
2005-08-01 14:37 EDT, Ken Ganong
no flags Details

  None (edit)
Description Ken Ganong 2005-08-01 14:37:53 EDT
Basically, if monitoring is not enabled during the installation of a satellite,
enabling monitoring will result in an environment not suitable for monitoring
(known problems: some needed and assumed data (like the default 'Panic
Destination' contact method) is missing from the database).  An example
traceback caused by attempting to create a general, check nothing probe attached.

To replicate:
Enable monitoring with a satellite not installed with monitoring.
Create a system probe, which will generate 500.
Comment 1 Ken Ganong 2005-08-01 14:37:55 EDT
Created attachment 117352 [details]
Create Probe Traceback
Comment 2 Mike McCune 2005-08-01 14:39:39 EDT
moving to the right tracking bug.
Comment 3 Max Spevack 2005-08-29 14:42:01 EDT
mass assign QA contact for rhn410 bugs
Comment 4 Mike McCune 2005-09-30 16:58:19 EDT
The real solution to this bug is to properly warn the user when they enable
monitoring that they need to run the enable-monitoring.pl script.
Comment 5 Miroslav Suchý 2007-10-18 09:33:51 EDT
I tested this under new satellite 510 and this scenario work there. 
Comment 6 Mike McCune 2008-05-13 15:57:08 EDT
Closing as WONTFIX.  If anyone wants this bug to be reopened feel free to do so!

Note You need to log in before you can comment on or make changes to this bug.