Bug 164842 - Incorrect build time for requeued jobs
Incorrect build time for requeued jobs
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: extras buildsys (Show other bugs)
unspecified
All Linux
medium Severity low
: ---
: ---
Assigned To: Seth Vidal
Jeremy Katz
http://buildsys.fedoraproject.org/bui...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 14:46 EDT by Ville Skyttä
Modified: 2007-04-18 13:30 EDT (History)
1 user (show)

See Also:
Fixed In Version: plague-0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 15:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-08-01 14:46:00 EDT
cf. http://buildsys.fedoraproject.org/build-status/job.psp?uid=117 
 
libapreq2 for devel has been requeued a couple of times and failed due to 
various reasons.  It finally succeeded, but the build time seems to reflect 
the period from when a package is submitted for the first time until the 
completion of the last try.  It was 112 minutes before I requeued it today, 
and now it's 5040 minutes. 
 
At least the intervals when the build has not been active during the job's 
life cycle should be excluded from this value.  Or perhaps just forget about 
when the job was first submitted, and list only the duration of the latest 
(requeued) build as the build time.
Comment 1 Dan Williams 2005-08-19 15:07:35 EDT
fixed in plague-0.3 and later

Note You need to log in before you can comment on or make changes to this bug.