Bug 164856 - Cannot start firefox profile manager when firefox is running
Summary: Cannot start firefox profile manager when firefox is running
Status: CLOSED DUPLICATE of bug 172864
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-01 20:48 UTC by Anders Kaseorg
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 20:19:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anders Kaseorg 2005-08-01 20:48:13 UTC
In firefox 1.0, firefox -P started the profile manager, and firefox -P <profile>
opened a new window in the specified profile. But in firefox 1.1 from Rawhide,
both of these commands always open a new window in whatever profile is currently
running, making it impossible to use two profiles at once.

Version-Release number of selected component (if applicable):
firefox-1.1-0.2.5.deerpark.alpha2

Comment 1 Bryan O'Sullivan 2006-02-18 15:48:10 UTC
I never saw this problem with any firefox release until I started running fc5t2,
and now I can only have one profile open at a time.

I upgraded to rawhide firefox (1.5.0.1-1.3), with no difference.

Comment 2 Till Maas 2007-04-17 13:26:52 UTC
It is more than a year since the last comment and there is no response from you
Chrisptopher, will this ever be fixed or this is intendet beheaviour? For me,
this is pretty annying, because having several profiles, where I can run at most
one is not very useful. 

Comment 3 Till Maas 2007-04-17 13:35:17 UTC
Using "/usr/lib/firefox-1.5.0.10/firefox-bin -ProfileManager" displays the
ProfileManager, so this seems to be a bug in the firefox wrapper script.

Comment 4 Christopher Aillon 2007-04-17 14:59:43 UTC
Duping to another bug with the explanation.  This is by design upstream.

*** This bug has been marked as a duplicate of 172864 ***

Comment 5 Till Maas 2007-04-17 16:35:02 UTC
(In reply to comment #4)
> Duping to another bug with the explanation.  This is by design upstream.
> 
> *** This bug has been marked as a duplicate of 172864 ***

There it is explained, that firefox cannot do this, but why did it work when I
started it this way?

"/usr/lib/firefox-1.5.0.10/firefox-bin -ProfileManager"

After this or maybe something other I tried, it also works now directly with

firefox -ProfileManager

and I can run several profiles at once, I tried with three different instances
and sucessfully installed an extension for one of these instances. Firefox even
warned me, when I wanted to open an already used profile again, which only makes
sence when it is possible to run several profiles at once. So somehow there is a
way to make this work with the binaries that are currently used in Fedora.



Comment 6 Christopher Aillon 2007-04-17 16:43:32 UTC
Simply because the code got disabled by default, not removed.  My understanding
is that it will be removed in a future version.  I believe you can do similar
things with the upstream version as well, but the profile switching code is
considered of inferior quality and just is not supported anymore.

Also, with fedora 7 containing fast user switching, it is easy to simply swap to
a different user for the entire desktop, making this less relevant.

Comment 7 Till Maas 2007-05-08 20:19:58 UTC
(In reply to comment #6)
> Simply because the code got disabled by default, not removed.  My understanding
> is that it will be removed in a future version.  I believe you can do similar
> things with the upstream version as well, but the profile switching code is
> considered of inferior quality and just is not supported anymore.

Sad, sad. :-(

> Also, with fedora 7 containing fast user switching, it is easy to simply swap to
> a different user for the entire desktop, making this less relevant.

Not really, because it does not help me, when I want to use my favorite browser
as the same system user with differen skins / or plugins loaded. E.g. a normal
browser just to browse and another to develop web pages with all the fancy
plugins or to test web applications with even other plugins, like e.g. the
tamper data extension for the wep-app test but another browser instance without
it to read documentation and dozens of other use cases.

Sadly I am not able to reproduce the use of two firefox instances, so I close
this bug again. :-C

*** This bug has been marked as a duplicate of 172864 ***


Note You need to log in before you can comment on or make changes to this bug.