Bug 164868 - Impure removable media freezes system
Impure removable media freezes system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 21:57 EDT by Jim Cornette
Modified: 2015-01-04 17:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 02:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
message excerpts from all messages logs on system (31.68 KB, text/plain)
2005-08-03 11:58 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2005-08-01 21:57:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.7.10-3

Description of problem:
When inserting removable media (DVD from customer in my case), the system would stop dead in its tracks and would have to be turned off forcefully (holding in power button). The kernel has since beeen replaced where the surprising to me system freeze happened.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert DVD from customer, not expecting fingerprints, scratches on DVD
2. notice ICON for media on desktop.
3. Try to move mouse or perform keyboard entries
  

Actual Results:  1. Disc is in good enough condition to become mounted
2. Last sign of activity, screen full of last activity
3. nothing works, forced to kill system 

Expected Results:  I expected an error dialog box specifying media was unreadable. I did not expect the system to freeze.

Additional info:

I believe this problem to be common with damaged removable media being fairly common. There should be some mechanism to not have removable media lock up a system. Direct I/O vs. governed I/O control of removable media is desired.

I marked this bug High since system needs killed vs. graceful shutdown.
Comment 1 Dave Jones 2005-08-02 19:49:24 EDT
is this on the latest errata kernel ?  There were some bugs fixed in this area
which could explain such behaviour.
Comment 2 Jim Cornette 2005-08-03 11:55:00 EDT
The lockup happened with the 1390_FC4smp kernel. I used the same defective discs
in the same DVD recorder and did not experience a system freeze. With the prior
kernel, it happened on several DVDs that the customer provided. The DVDs were
recorded on DVD-R and being read from a DVD+RW recorder.
Attached is an excerpt from the message logs using.
cat message* |grep hdd

The 1398_FC4smp kernel seems to work reasonably well.
Comment 3 Jim Cornette 2005-08-03 11:58:07 EDT
Created attachment 117413 [details]
message excerpts from all messages logs on system

These messages were derived using 
cat message* |grep hdd
and contain some of the lockup experienced which froze the system with
1390_FC4smp kernel.
Comment 4 Dave Jones 2005-08-04 02:28:30 EDT
ok, as 1398 works, I'll close this.

Thanks for retesting.
Comment 5 Jim Cornette 2005-08-05 18:08:56 EDT
There were a lot of buffer related errors. Is this problem preventable by
clearing the device buffers? Probably not, just an idea.

Thanks!

Jm

Note You need to log in before you can comment on or make changes to this bug.