Bug 164878 - Repository permissions problem in rpmdevtools
Repository permissions problem in rpmdevtools
Status: CLOSED RAWHIDE
Product: Fedora Infrastructure
Classification: Retired
Component: cvs (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 05:16 EDT by Ville Skyttä
Modified: 2007-04-18 13:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 16:50:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-08-02 05:16:58 EDT
Something's wrong with the FS permissions in rpmdevtools CVS:  
  
**** Access allowed: scop is in ACL for fedora-rpmdevtools. 
Checking in check-buildroot; 
/cvs/fedora/fedora-rpmdevtools/check-buildroot,v  <--  check-buildroot 
new revision: 1.3; previous revision: 1.2 
cvs [commit aborted]: could not open lock file 
`/cvs/fedora/fedora-rpmdevtools/,check-buildroot,': Permission denied
Comment 1 Warren Togami 2005-08-02 06:17:48 EDT
Hmm, I see nothing obviously wrong with the file permissions in /cvs/fedora...
Comment 2 Ville Skyttä 2005-08-02 06:22:17 EDT
What about the perms of the /cvs/fedora/fedora-rpmdevtools directory and its 
subdirs? 
Comment 3 Warren Togami 2005-08-02 06:28:09 EDT
[root@cvs-int fedora-rpmdevtools]# ls -lR
.:
total 236
drwxrwsr-x    2 505      cvsfedora     4096 Mar 24 11:32 Attic/
-r--r--r--    1 505      cvsfedora     1954 Jul  8 13:20 check-buildroot,v
-r--r--r--    1 505      cvsfedora     1716 Jul  8 13:20 check-rpaths,v
-r--r--r--    1 505      cvsfedora     4553 Jul  8 13:20 check-rpaths-worker,v
-r--r--r--    1 505      cvsfedora    18666 Jul  8 13:20 COPYING,v
drwxrwsr-x    3 508      cvsfedora     4096 Jul  8 13:24 devgpgkeys/
drwxrwsr-x    3 508      cvsfedora     4096 Jul  8 13:20 emacs/
-r--r--r--    1 505      cvsfedora     4627 Jul  8 13:20 fedora-buildrpmtree,v
-r--r--r--    1 505      cvsfedora     2150 Jul  8 13:20 fedora-diffarchive,v
-r--r--r--    1 505      cvsfedora     3641 Jul  8 13:20 fedora-extract,v
-r--r--r--    1 505      cvsfedora    11578 Jul  8 13:20 fedora-installdevkeys,v
-r--r--r--    1 505      cvsfedora    23959 Jul  8 13:20 fedora-kmodhelper,v
-r--r--r--    1 505      cvsfedora     2370 Jul  8 13:20 fedora-md5,v
-r--r--r--    1 505      cvsfedora     2742 Jul  8 13:20 fedora-newrpmspec,v
-r--r--r--    1 505      cvsfedora    16849 Jul  8 13:20 fedora-rmdevelrpms,v
-r--r--r--    1 505      cvsfedora     6013 Jul  8 13:20 fedora-rpmchecksig,v
-r--r--r--    1 505      cvsfedora    41488 Jul  8 13:24 fedora-rpmdevtools.spec,v
-r--r--r--    1 505      cvsfedora     2040 Jul  8 13:20 fedora-rpmvercmp,v
-r--r--r--    1 505      cvsfedora     4472 Jul  8 13:20 fedora-wipebuildtree,v
-r--r--r--    1 505      cvsfedora     1708 Jul  8 13:20 mkdist.sh,v
-r--r--r--    1 505      cvsfedora     1095 Jul  8 13:20 rmdevelrpms.conf,v
-r--r--r--    1 505      cvsfedora     9513 Jul  8 13:20 rpminfo,v
-r--r--r--    1 505      cvsfedora     2262 Jul  8 13:20 spectemplate-minimal.spec,v
-r--r--r--    1 505      cvsfedora     4172 Jul  8 13:20 spectemplate-perl.spec,v
-r--r--r--    1 505      cvsfedora     3177 Jul  8 13:20 spectemplate-python.spec,v
-r--r--r--    1 505      cvsfedora     2543 Jul  8 13:20 template.init,v
drwxrwsr-x    2 505      cvsfedora     4096 Jul  8 13:20 test/

./Attic:
total 24
-r--r--r--    1 505      cvsfedora      864 Oct 31  2003 develrpms.conf,v
-r--r--r--    1 505      cvsfedora     3203 Dec 17  2004 fedora-diffrpm,v
-r--r--r--    1 505      cvsfedora     2137 Mar 21 13:35 fedora-pkgannfmt,v
-r--r--r--    1 505      cvsfedora     4069 Dec 17  2004 fedora-unrpm,v
-r--r--r--    1 505      cvsfedora     7709 Mar 24 11:32 spectemplate.spec,v

./devgpgkeys:
total 32
drwxrwsr-x    2 505      cvsfedora     4096 Jul  8 13:24 Attic/
-r--r--r--    1 505      cvsfedora     2223 Jul  8 13:20 RPM-GPG-KEY-beta,v
-r--r--r--    1 505      cvsfedora     2306 Jul  8 13:20 RPM-GPG-KEY-fedora-extras,v
-r--r--r--    1 505      cvsfedora     1621 Jul  8 13:20
RPM-GPG-KEY-fedora-rawhide,v
-r--r--r--    1 505      cvsfedora     1592 Jul  8 13:20 RPM-GPG-KEY-fedora-test,v
-r--r--r--    1 505      cvsfedora     2035 Jul  8 13:20 RPM-GPG-KEY-fedora,v
-r--r--r--    1 505      cvsfedora     1749 Jul  8 13:20 RPM-GPG-KEY-rawhide,v
-r--r--r--    1 505      cvsfedora     2792 Jul  8 13:20 RPM-GPG-KEY,v

./devgpgkeys/Attic:
total 84
-r--r--r--    1 505      cvsfedora     2029 Mar 21 13:28 1B4259B3,v
-r--r--r--    1 505      cvsfedora     2009 Mar 21 13:28 2EB1D4BD,v
-r--r--r--    1 505      cvsfedora     2248 Mar 21 13:28 3C9DB0AA,v
-r--r--r--    1 505      cvsfedora     2118 Mar 21 13:28 3ED6F034,v
-r--r--r--    1 505      cvsfedora     2260 Mar 21 13:28 3FF87D98,v
-r--r--r--    1 505      cvsfedora     2625 Mar 21 13:28 54A2ACF1,v
-r--r--r--    1 505      cvsfedora     2357 Mar 21 13:28 55F3AA6F,v
-r--r--r--    1 505      cvsfedora     2784 Mar 21 13:28 69886CC7,v
-r--r--r--    1 505      cvsfedora     1845 Mar 21 13:28 736A7502,v
-r--r--r--    1 505      cvsfedora     2601 Mar 21 13:28 8DF56D05,v
-r--r--r--    1 505      cvsfedora     2239 Mar 21 13:28 8E279021,v
-r--r--r--    1 505      cvsfedora     2130 Mar 21 13:28 B8AF1C54,v
-r--r--r--    1 505      cvsfedora     5306 Mar 21 13:28 BCD241CB,v
-r--r--r--    1 505      cvsfedora     2009 Dec 28  2003 BETA-RPM-GPG-KEY,v
-r--r--r--    1 505      cvsfedora     2693 Mar 21 13:28 C58CF1CB,v
-r--r--r--    1 505      cvsfedora     3946 Mar 21 13:28 D881FF60,v
-r--r--r--    1 505      cvsfedora     1652 Nov 23  2003 E418E3AA,v
-r--r--r--    1 505      cvsfedora     3215 Mar 21 13:28 E421D146,v
-r--r--r--    1 505      cvsfedora     2471 Mar 21 13:28 E42D547B,v
-r--r--r--    1 505      cvsfedora     2160 Jul  8 13:24 RPM-GPG-KEY-fedora.us,v

./emacs:
total 8
drwxrwsr-x    2 505      cvsfedora     4096 Mar 20 10:26 Attic/
-r--r--r--    1 505      cvsfedora     3737 Jul  8 13:20 fedora-init.el,v

./emacs/Attic:
total 4
-r--r--r--    1 505      cvsfedora     1643 Mar 20 10:26 rpm-spec-mode.el.patch,v

./test:
total 4
-r--r--r--    1 505      cvsfedora     1526 Jul  8 13:20 fedora-kmodhelper-test.sh,v
Comment 4 Ville Skyttä 2005-08-02 06:33:29 EDT
Still missing some info: ls -ld /cvs/fedora/fedora-rpmdevtools 
Comment 5 Warren Togami 2005-08-02 06:35:31 EDT
[root@cvs-int fedora]# ls -ld /cvs/fedora/fedora-rpmdevtools
drwxrwsr-x    6 508      cvsfedora     4096 Jul  8 13:24
/cvs/fedora/fedora-rpmdevtools/
Comment 6 Ville Skyttä 2005-08-08 15:24:48 EDT
Any news/ideas about this? 
Comment 7 Warren Togami 2005-08-09 21:48:00 EDT
I am confused.  I was able to modify the COPYING and check-buildroot file using
my remote SSH cvs account with no problem.
Comment 8 Warren Togami 2005-08-17 01:22:09 EDT
Anyone know if we are using more fine-grained CVS ACL's?  Where can I look this
configuration?
Comment 9 Ville Skyttä 2005-08-17 05:49:59 EDT
/cvs/fedora/CVSROOT could be a place to look. 
 
But to me the error looks like just a regular one that comes from the 
filesystem, not any ACL implementation.  The ACL implementations I'm aware of 
do not have anything to do with creating lock files (which is where the error 
comes from). 
 
Is my account (scop) in the cvsfedora group?  Any other group differences 
between my account and yours? 
Comment 10 Warren Togami 2005-08-17 05:54:49 EDT
Crap!  I don't see "scop" in cvsfedora.  Please request and I'll approve you now.
Comment 11 Warren Togami 2005-08-17 06:00:37 EDT
Sorry I'm falling asleep now.  Maybe Sopwith can approve you in a few hours, or
I'll do it when I wake up.
Comment 12 Ville Skyttä 2005-08-18 01:49:40 EDT
Yep, works now, thanks. 

Note You need to log in before you can comment on or make changes to this bug.