Bug 164917 - yum's rpm-python dependency needs a version
Summary: yum's rpm-python dependency needs a version
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-02 17:41 UTC by Has Cat
Modified: 2014-01-21 22:52 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-09-21 19:30:18 UTC


Attachments (Terms of Use)

Description Has Cat 2005-08-02 17:41:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Internet Explorer/1.0.4

Description of problem:
Updating yum from fc3 to fc4 doesn't check for an updated version of rpm-python. Yum does require an update of python to 2.4, so rpm-python (based on python 2.3) doesn't work anymore. 


Version-Release number of selected component (if applicable):
yum-2.3.2-7

How reproducible:
Always

Steps to Reproduce:
1. use yum to update yum
  

Actual Results:  yum stopped working because rpm-python is outdated

Expected Results:  yum should have provided a dependency on a newer version of rpm-python, so it would be included in the update.

Additional info:

Comment 1 Jeremy Katz 2005-09-21 19:30:18 UTC
This actually is fixed with FC4 as we've introduced the python-abi autodeps


Note You need to log in before you can comment on or make changes to this bug.