Bug 164934 - Undefined libtasn1 symbols in libgnutls-openssl
Undefined libtasn1 symbols in libgnutls-openssl
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnutls (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 17:00 EDT by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 10:08:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-08-02 17:00:05 EDT
GNU TLS library is built --with-included-libtasn1, but somehow libtasn1 symbols
are undefined when linking against it:

$ gcc test.c -o test -lgnutls-openssl
/usr/lib/gcc/i386-redhat-linux/4.0.1/../../../libgnutls-openssl.so: undefined
reference to `asn1_delete_structure'
/usr/lib/gcc/i386-redhat-linux/4.0.1/../../../libgnutls-openssl.so: undefined
reference to `asn1_create_element'
/usr/lib/gcc/i386-redhat-linux/4.0.1/../../../libgnutls-openssl.so: undefined
reference to `asn1_der_decoding'
collect2: ld returned 1 exit status

$ nm -uD /usr/lib/libgnutls-openssl.so.11.1.25  | grep asn1
         U asn1_create_element
         U asn1_delete_structure
         U asn1_der_decoding
Comment 1 Tomas Mraz 2005-08-03 04:01:42 EDT
The problem is the libgnutls.so which contains the included minitasn1 doesn't
export its symbols.

The solution would be to either export the asn1_.... symbols from libgnutls and
link with it or to include minitasn1 not only in the libgnutls but also in
libgnutls-openssl.

The decision should be done upstream.
Comment 2 Michael Schwendt 2005-08-03 06:28:11 EDT
Since this problem blocks Fedora Extras' libetpan, where can I track where you
reported this upstream?
Comment 3 Michael Schwendt 2005-08-03 07:59:16 EDT
Also, do you mind if this ticket is kept open until the issue is fixed? A broken
libgnutls-openssl in Core is useless. [We could work around it with linking
libtasn1 from Extras, but that would be an ugly hack.]
Comment 4 Tomas Mraz 2005-08-03 09:41:37 EDT
This is fixed in upstream gnutls-1.2.6 which I'm planning upgrade to for FC5.

I don't think this will be fixed in gnutls-1.0.x series (FC3/4).
Comment 5 Michael Schwendt 2005-08-03 10:08:02 EDT
Okay. I see nothing in FC4 links against libgnutls-openssl. So I think libetpan
will have to use OpenSSL instead.

Note You need to log in before you can comment on or make changes to this bug.