Bug 1649432 - cluster getting replicated on subsequent host discoveries on RHV
Summary: cluster getting replicated on subsequent host discoveries on RHV
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.4
Hardware: All
OS: All
medium
low
Target Milestone: GA
: 5.9.7
Assignee: Boriso
QA Contact: Sudhir Mallamprabhakara
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-13 15:42 UTC by Felix Dewaleyne
Modified: 2018-12-17 15:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 21:28:05 UTC
Category: ---
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)

Description Felix Dewaleyne 2018-11-13 15:42:42 UTC
Description of problem:
if due to a network issue host discovery gets triggered multiple times, clusters get duplicated in CloudForms

Version-Release number of selected component (if applicable):
5.9.4

How reproducible:
all the time

Steps to Reproduce:
1. set up RHV with several hosts
2.set up cloudforms to the RHV
3.simulate network issues, causing hosts to be discovered again and again

Actual results:
the cluster gets duplicated in cloudforms despite all having the same UUIDs

Expected results:
the cluster isn't added since it is the same.

Additional info:
this is due to a network issue that leads to triggering the discovery of hosts multiple times in RHV.

Comment 3 dmetzger 2018-12-11 21:28:05 UTC
Environmental issue.

Comment 4 Ilanit Stein 2018-12-17 08:53:01 UTC
I failed to reproduce this bug, using the bellow flow.

Versions:
RHV-4.2.8-0.1.el7ev 
CFME-5.9.6.3.20181126231255_be48af6

Flow:
Have a RHV with one host.
Disable fencing on RHV cluster (so that vdsmd service won't be started automatically)
Run on host: 'systemctl stop vdsmd'
On RHV side, the host become 'non responsive'
On CFME side, the host is marked with '?'

Then run on host 'systemctl start vdsmd'
On RHV side, the host became back up.
On CFME, after automatic refresh, the host became up again.


Cluster status on CFME:
The RHV cluster was NOT duplicated.
I checked it under 'Clusters' tab, in provider details page, cluster field,
and in Host details page, cluster field.

I repeated the above flow twice, however did not encounter cluster duplicate.

Maybe this is specific the versions in the reported env, or maybe some additional conditions to have it reproduce.

Comment 5 Martin Perina 2018-12-17 12:30:36 UTC
Based on above changing to CLOSED-WORKSFORME, feel free to reopen if you were able to reproduce with latest CFME/RHV releases and provide reproducing steps and logs


Note You need to log in before you can comment on or make changes to this bug.