Bug 164949 - Tux Typing leaves does not restore video settings upon exit
Tux Typing leaves does not restore video settings upon exit
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tuxtype2 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 20:18 EDT by Robert Styma
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.5.3-1.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-20 12:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Styma 2005-08-02 20:18:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Type Typing goes to full screen mode.  Upon exit the display is still in
640x480 mode and you have to scroll around to see the whole desktop.  Logging
off and then back on again resolves the problem.  Some programs have to be reconfigured to get them to the correct sizes.  
cat cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 8
model name      : AMD Duron(tm) Processor
stepping        : 1
cpu MHz         : 1210.697
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips        : 2400.25
                         xdpyinfo
name of display:    :0.0
version number:    11.0
vendor string:    The X.Org Foundation
vendor release number:    60802000
X.Org version: 6.8.2
maximum request size:  16777212 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  window 0x1400002, revert to PointerRoot
number of extensions:    31
    BIG-REQUESTS
    DAMAGE
    DOUBLE-BUFFER
    DPMS
    Extended-Visual-Information
    GLX
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RANDR
    RECORD
    RENDER
    SECURITY
    SGI-GLX
    SHAPE
    SYNC
    TOG-CUP
    VNC-EXTENSION
    X-Resource
    XC-APPGROUP
    XC-MISC
    XFIXES
    XFree86-Bigfont
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1024x768 pixels (382x283 millimeters)
  resolution:    68x69 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
  root window id:    0x5f
  depth of root window:    24 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x20
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 16777215
  options:    backing-store NO, save-unders NO
  largest cursor:    32x32
  current input event mask:    0xfa0033
    KeyPressMask             KeyReleaseMask           EnterWindowMask          
    LeaveWindowMask          StructureNotifyMask      SubstructureNotifyMask   
    SubstructureRedirectMask FocusChangeMask          PropertyChangeMask       
    ColormapChangeMask       
  number of visuals:    8
  default visual id:  0x23
  visual:
    visual id:    0x23
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits

Video Card:
nVidia Corporation NV5 [RIVA TNT2/TNT2 Pro]


Version-Release number of selected component (if applicable):
tuxtype2.i386                            1.5.2-3 

How reproducible:
Always

Steps to Reproduce:
1. Screen size is set to 1024x768 pixels
2. Start Tux Typing
3. Play falling fish on easy mode for a bit
4. Exit the program.  Screen does not go back to the correct dimensions
  

Actual Results:  It appeared that the desktop was 1024x768, but only 640x480 was displayed at a
time.  If you moved the mouse to the edge of the screen, the other parts of the
screen would show up.  Had to log off to get the screen back to normal.

Expected Results:  As with most of the stuff under games, the screen should revert to it's
original state.  No relevant messages in /var/log/messages.

Additional info:
Comment 1 Steven Pritchard 2006-03-16 16:51:48 EST
That's very odd.  I can't reproduce the problem.  The only ideas I have are to
try the proprietary nvidia driver from rpm.livna.org (I *think* it will still
drive the TNT2 cards), try rebuilding the 1.5.3 package that's in the
development/FC5 tree to see if that changes anything, or try FC5 when it comes
out next week to see if the newer version of X.org fixes the problem.
Comment 2 Steven Pritchard 2006-03-16 17:05:26 EST
Thinking about this a little more, I've decided to update the FC4 package to
1.5.3.  The build system is down at the moment, so it will take a little while
for the new package to push out.

Either try the new package once it is available, or, like I said before, rebuild
the source rpm from development and try that.
Comment 3 Robert Styma 2006-03-19 09:45:48 EST
Hello Steve, your fix came through yum update this morning and it works just
great.  Thank you for your time and efforts.

Note You need to log in before you can comment on or make changes to this bug.