Bug 164952 - Linux doesn't boot when partition name has a space in it
Linux doesn't boot when partition name has a space in it
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 20:55 EDT by its.a.thing
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 17:48:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description its.a.thing 2005-08-02 20:55:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Yesterday I totally formated my hard drive and made a totally new partition table. I labeled the ext3 partition I was installing Fedora on as "Fedora Core 4 Stentz" and the ext3 partition I was going to install Debian GNU/Linux Sarge "Debian GNU/Linux 3.1 Sarge" and mounted it on /debian. Anaconda gave me no errors. Once I installed, I tried to boot my new installation. Upon boot, Linux froze. This was the screen that it froze on:
{picture of Tux}
Red Hat nash version 4.2.15 starting
mount: missing mount point
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!

The only extra kernel parameter I entered in Anaconda was "vga=794" so I could get a small font in terminals.

Next I booted into System Rescue CD, mounted my Fedora and /boot partition and edited /etc/fstab and /boot/grub/grub.conf so they would use /dev/hda6 and /dev/hda7 instead of the partition names. That didn't help. Next I tried renaming the partitions to "Fedora" and "Debian". That didn't work either. I tried reinstalling and doing the same things. I got the same errors.

Last I formatted all the partitions and made sure their names didn't have spaces. I'm now able to boot into Fedora.



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Make a partition with a space in its name.
2. Install Fedora Core 4 with the new partition as /
3. Attempt to boot Fedora Core 4.
  

Actual Results:  Linux froze with:
{picture of Tux}
Red Hat nash version 4.2.15 starting
mount: missing mount point
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!

Expected Results:  I expected Fedora to boot with no problems.

Additional info:

I have installed from the install media before and since it has just been sitting in CD cases.

System specs:
    * 2.26 GHz Intel Pentium 4 processor
    * 533MHz system bus
    * 512K Level 2 cache memory
    * Intel Full ATX RAID-ready memory system board
    * 512MB DRAM (2 x 256MB) system memory
    * 266MHz double data rate SDRAM
    * 80GB Western Digital Ultra ATA/100 (7200RPM) server grade hard drive
    * 40x12x40 CD-ROM/CD-RW drive (installed from this drive)
Output of fdisk -l:
Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          33      265041   83  Linux -- /boot
/dev/hda2              34         686     5245222+  83  Linux -- /usr/local
/dev/hda3             687        1600     7341705   83  Linux -- /home
/dev/hda4            1601        9729    65296192+   f  W95 Ext'd (LBA)
/dev/hda5            1601        1665      522081   82  Linux swap / Solaris -- swap
/dev/hda6            1666        3623    15727603+  83  Linux -- Fedora Core 4 Stentz
/dev/hda7            3624        5581    15727603+  83  Linux -- Debian GNU/Linux 3.1 Sarge
Comment 1 Chris Lumens 2005-08-03 16:39:42 EDT
You did the partitioning and filesystem labelling before running anaconda?
Comment 2 its.a.thing 2005-08-03 23:56:50 EDT
Yes, I did all partitioning and labeling with QTParted on System Rescue CD.
Comment 3 Jeremy Katz 2005-08-08 17:48:31 EDT
spaces are not an allowed character for filesystem labels.  This would be a bug
in qtparted that it allowed you to have them (the labels you used are also far
longer than is allowed in the ext[23] metadata)

Note You need to log in before you can comment on or make changes to this bug.