Bug 164963 - plague-client bogus 'usage' text
plague-client bogus 'usage' text
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plague (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 00:26 EDT by Ralf Corsepius
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: long ago
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 11:03:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-08-03 00:26:48 EDT
Description of problem:
plague-client's "usage" on "email" doesn't match with implementation.

Version-Release number of selected component (if applicable):
Seth's plague-client-0.2

How reproducible:
Deterministic.

Steps to Reproduce:
1. 
# plague-client
Usage:
package-builder.py <command>

      <command> is one of:
      build [package_name] [cvs_tag | srpm_path] [target]
      list
      list <status>
      list <email> <status>
      kill <jobid>
      update_builders
      list_builders

2.
# plague-client list ralf@links2linux.de needsign
Error: invalid option 'ralf@links2linux.de'

Apparently, the correct command syntax is:
plague-client list email <email>

while
plague-client list email <email> <status>
doesn't seem to work at all.

# plague-client list email ralf@links2linux.de needsign
Error: invalid options.
Comment 1 Seth Vidal 2005-08-03 00:33:04 EDT
I didn't write plague-client or much of plague at all.

Dan did. There's no need to convey possession of it anyway.

the format that seems to work is:
plague-client list email ralf@links2linux.de status needsign.
Comment 2 Ralf Corsepius 2005-08-03 00:47:26 EDT
(In reply to comment #1)
> I didn't write plague-client or much of plague at all.
> 
> Dan did. There's no need to convey possession of it anyway.
I didn't mean to accuse anybody - You're just the person bugzilla assigns
buildsys  PRs to.
 
> the format that seems to work is:
> plague-client list email ralf@links2linux.de status needsign.

OK, then somebody might want to change plague-client's usage to
 list email <email> [status <status>]
or whatever the "correct" usage is.
Comment 3 Seth Vidal 2005-08-03 00:49:49 EDT
I wasn't taking it as an accusation. I just wanted to give credit in the right
places.

Now about the change. I think it might be maybe more worthwhile to make the
interface more optparsing:

plague-client --email=foo --status=bar list

Dan, what do you think?
Ralf, does that make sense to you?
Comment 4 Ralf Corsepius 2005-08-03 01:52:27 EDT
(In reply to comment #3)
> Ralf, does that make sense to you?
Yes.

Actually, I would propose to apply
http://www.opengroup.org/onlinepubs/009695399/basedefs/xbd_chap12.html
+ getopt_long

i.e. short options + (optional) long options.

IMO, this also is the essence also recommended by
http://www.gnu.org/prep/standards/standards.html#Command_002dLine-Interfaces


 

Comment 5 Dan Williams 2005-08-19 15:03:33 EDT
Patches accepted for getopt :)
Comment 6 Christian Iseli 2007-01-19 02:20:26 EST
This bug hasn't been updated in a long time and targets FE devel.
Could you please check that it still occurs with current FE devel and update
accordingly ?

Thanks.
Comment 7 Ralf Corsepius 2007-01-19 03:01:20 EST
Bug seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.