Bug 164969 - ttmkfdir -d /somewhere/bogus segfaults
Summary: ttmkfdir -d /somewhere/bogus segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ttmkfdir   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Liang Zhang
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-03 06:18 UTC by Warren Togami
Modified: 2015-04-07 03:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 05:54:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2005-08-03 06:18:16 UTC
ttmkfdir -d /somewhere/bogus segfaults

Tested Failures
===============
i386   RHEL4U1
i386   FC4
x86_64 FC4

Program received signal SIGSEGV, Segmentation fault.
0x00b9aa16 in readdir () from /lib/libc.so.6
(gdb) bt
#0  0x00b9aa16 in readdir () from /lib/libc.so.6
#1  0x0804eef8 in directory::scan (this=0x8504460, dir=@0x11) at directory.cpp:23
#2  0x0804a92b in main (argc=0, argv=0xbfb68e14) at ttmkfdir.cpp:63
#3  0x00b26de6 in __libc_start_main () from /lib/libc.so.6
#4  0x0804a231 in _start ()

Comment 1 Liang Zhang 2005-10-08 08:43:50 UTC
Already fixed this bug in FC-5 and FC-4.

Comment 2 Warren Togami 2005-10-08 12:02:28 UTC
Was this issued in a RHEL4 U?


Comment 3 Liang Zhang 2005-10-10 01:55:12 UTC
The patch can fix this bug in RHEL4, but I don't commit it to the tree of RHEL4.
I have already committed the patch to the tree of devel and 
FC-4.

Comment 4 Warren Togami 2005-10-10 03:09:55 UTC
Reassigning to RHEL4.  This alone is not important, but if we push other
ttmkfdir fixes in the future we can include this too.

Comment 5 Liang Zhang 2005-10-10 06:30:55 UTC
I am ready to reassign to RHEL4-U3. Because this bug is not important and
urgent, I don't need to reassign to RHEL4-U2-errata or RHEL4-U1-errata.

Comment 6 Liang Zhang 2006-01-17 05:53:45 UTC
The bug was fixed in Rawhide. So close it.


Note You need to log in before you can comment on or make changes to this bug.