Bug 164984 - Installer crashed when using sata-harddisk
Installer crashed when using sata-harddisk
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 06:44 EDT by Sascha Ullmann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 17:13:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sascha Ullmann 2005-08-03 06:44:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Installing Fedora 4 (CD-Installation iso.image) on my System is not a problem, if I use an old IDE-Harddisk. But my Mainboard, a MSI K8N Neo4, supports SATA based on NVidia nforce4 too. When I start the installation of linux on my Samsung SP0812C, there is always a crash during the formating-process. Raid is disabled and i used automatic partitioning.

Version-Release number of selected component (if applicable):
2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1.deactivate raid in the bios
2.booting from cd1 of fedora 4
3.doing the installation-process
4.crash when anaconda is starting to format (sometimes a little bit later on)
  

Actual Results:  An error message

Expected Results:  formatting the harddisk and going on with package-installation

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 49, in findRootParts
    id.rootParts = findExistingRoots(intf, id, chroot)
  File "/usr/lib/anaconda/upgrade.py", line 80, in findExistingRoots
    upgradeany = upgradeany)
  File "/usr/lib/anaconda/partedUtils.py", line 620, in findExistingRootPartitions
    for fs in fsset.getFStoTry(dev):
  File "/usr/lib/anaconda/fsset.py", line 2494, in getFStoTry
    if isValidXFS(device):
  File "/usr/lib/anaconda/fsset.py", line 2425, in isValidXFS
    buf = os.read(fd, 4)
OSError: [Errno 5] Eingabe-/Ausgabefehler

....

/tmp/anaconda.log:
* modules to insert vgastate vga16fb
* loaded vgastate from /modules/modules.cgz
* loaded vga16fb from /modules/modules.cgz
* inserted /tmp/vgastate.ko
* inserted /tmp/vga16fb.ko
* load module set done
* 506120 kB are available
* modules to insert cramfs fat vfat sunrpc lockd nfs loop isofs floppy edd pcspkr
* loaded cramfs from /modules/modules.cgz
* loaded fat from /modules/modules.cgz
* loaded vfat from /modules/modules.cgz
* loaded sunrpc from /modules/modules.cgz
* loaded lockd from /modules/modules.cgz
* loaded nfs from /modules/modules.cgz
* loaded loop from /modules/modules.cgz
* loaded floppy from /modules/modules.cgz
* loaded edd from /modules/modules.cgz
* loaded pcspkr from /modules/modules.cgz
* module(s) isofs not found
* inserted /tmp/cramfs.ko
* inserted /tmp/fat.ko
* inserted /tmp/vfat.ko
* inserted /tmp/sunrpc.ko
* inserted /tmp/lockd.ko
* inserted /tmp/nfs.ko
* inserted /tmp/loop.ko
* inserted /tmp/floppy.ko
* inserted /tmp/edd.ko
* inserted /tmp/pcspkr.ko
* load module set done
* modules to insert cdrom ide-cd
* module(s) cdrom ide-cd not found
* load module set done
* modules to insert scsi_mod sd_mod sr_mod
* loaded scsi_mod from /modules/modules.cgz
* loaded sd_mod from /modules/modules.cgz
* loaded sr_mod from /modules/modules.cgz
* inserted /tmp/scsi_mod.ko
* inserted /tmp/sd_mod.ko
* inserted /tmp/sr_mod.ko
* load module set done
* looking for usb controllers
* no usb controller found
* no firewire controller found
* no pcic controller found
* probing buses
* finished bus probing
* modules to insert forcedeth libata sata_nv
* loaded forcedeth from /modules/modules.cgz
* loaded libata from /modules/modules.cgz
* loaded sata_nv from /modules/modules.cgz
* inserted /tmp/forcedeth.ko
* inserted /tmp/libata.ko
* inserted /tmp/sata_nv.ko
* load module set done
* trying to mount CD device hdc
* mntloop loop0 on /mnt/runtime as /mnt/source/Fedora/base/stage2.img fd is 11
* MD5SUM -> e0c53d27474c50cea2a00987e9d77c5f
* skipsectors = 15
* supported = 0
* Loading SELinux policy from /mnt/runtime/etc/selinux/targeted/policy/policy.19
* getting ready to spawn shell now
* modules to insert cdrom ide-cd
* module(s) cdrom ide-cd not found
* load module set done
* modules to insert
* load module set done
* probing buses
* finished bus probing
* modules to insert
* load module set done
* looking for video cards requiring agpgart module
* no video cards found
* modules to insert md raid0 raid1 xor raid5 raid6 msdos jbd ext3 reiserfs jfs exportfs xfs dm-mod dm-zero dm-mirror dm-snapshot
* loaded raid0 from /mnt/runtime/modules/modules.cgz
* loaded raid1 from /mnt/runtime/modules/modules.cgz
* loaded xor from /mnt/runtime/modules/modules.cgz
* loaded raid5 from /mnt/runtime/modules/modules.cgz
* loaded raid6 from /mnt/runtime/modules/modules.cgz
* loaded msdos from /mnt/runtime/modules/modules.cgz
* loaded jbd from /mnt/runtime/modules/modules.cgz
* loaded ext3 from /mnt/runtime/modules/modules.cgz
* loaded reiserfs from /mnt/runtime/modules/modules.cgz
* loaded jfs from /mnt/runtime/modules/modules.cgz
* loaded exportfs from /mnt/runtime/modules/modules.cgz
* loaded xfs from /mnt/runtime/modules/modules.cgz
* loaded dm-mod from /mnt/runtime/modules/modules.cgz
* loaded dm-zero from /mnt/runtime/modules/modules.cgz
* loaded dm-mirror from /mnt/runtime/modules/modules.cgz
* loaded dm-snapshot from /mnt/runtime/modules/modules.cgz
* module(s) md not found
* inserted /tmp/raid0.ko
* inserted /tmp/raid1.ko
* inserted /tmp/xor.ko
* inserted /tmp/raid5.ko
* inserted /tmp/raid6.ko
* inserted /tmp/msdos.ko
* inserted /tmp/jbd.ko
* inserted /tmp/ext3.ko
* inserted /tmp/reiserfs.ko
* inserted /tmp/jfs.ko
* inserted /tmp/exportfs.ko
* inserted /tmp/xfs.ko
* inserted /tmp/dm-mod.ko
* inserted /tmp/dm-zero.ko
* inserted /tmp/dm-mirror.ko
* inserted /tmp/dm-snapshot.ko
* load module set done
* Running anaconda script /usr/bin/anaconda
* Display mode = g
* Method = cdrom://hdc:/mnt/source
* Started mini-wm
* anaconda floppy device fd0
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'us', '-model', 'pc105', '-option', '']
* moving (1) to step welcome
* moving (1) to step language
* moving (1) to step keyboard
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'de', '-model', 'pc105', '-option', '', '-variant', 'nodeadkeys']
* moving (1) to step findrootparts
* lv is VolGroup00/LogVol00, size of 75200
* lv is VolGroup00/LogVol01, size of 992
Comment 1 Jeremy Katz 2005-08-08 17:50:19 EDT
Can you attach the complete dump you received?
Comment 2 Jeremy Katz 2005-09-21 17:13:03 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.

Note You need to log in before you can comment on or make changes to this bug.