Bug 1649884 - deb support is not removed from hammer
Summary: deb support is not removed from hammer
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 17:17 UTC by Mirek Zalewski
Modified: 2020-01-15 20:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-15 20:30:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mirek Zalewski 2018-11-14 17:17:25 UTC
Satellite does not support deb repositories that Foreman supports - references to them are removed from our product. I.e. when creating new repository, it is not possible to set type to `deb`.

hammer help still references deb in various ways and supports relevant flags.


Version:
Satellite 6.5 snap 3
pulp-server-2.17.1-1.el7sat.noarch
katello-3.9.0-0.11.rc2.el7sat.noarch
foreman-1.20.0-0.17.RC2.el7sat.noarch
satellite-6.5.0-3.beta.el7sat.noarch
tfm-rubygem-hammer_cli-0.15.1-1.el7sat.noarch


Steps to reproduce:
1. `hammer repository create --help |grep deb`
2. `hammer repository update --help |grep deb`
3. `hammer repository update --id :id --deb-releases jessie` (:id is id of yum repository)
4. `hammer repository create --product-id 3 --content-type deb --name deb-test`


Actual results:
For 1 and 2, returns 3 deb-related flags
For 3, succeeds
For 4, fails with message that deb is not supported type


Expected results:
There is no mention of deb in help messages.


Additional info:
help message for `hammer repository create` says that --content-type must be one of 'yum', 'deb', 'puppet', 'docker' or 'ostree', but possible value are 'docker', 'file', 'ostree', 'puppet', 'yum'.

Comment 2 Tomas Strachota 2018-11-15 09:43:48 UTC
Please note that we have the same problem in API where deb related parameters exist too. In fact hammer takes it from there and automatically creates options for the parameters. It would probably be easiest to fix this on server side.

Comment 3 Bryan Kearney 2019-12-03 16:34:56 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2020-01-15 20:30:47 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.