Bug 1649889 - Invocation of VirtualBox UI caused segfault in systemd
Summary: Invocation of VirtualBox UI caused segfault in systemd
Keywords:
Status: CLOSED DUPLICATE of bug 1648753
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 17:29 UTC by George R. Goffe
Modified: 2018-11-14 21:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-14 21:56:18 UTC
Type: Bug


Attachments (Terms of Use)

Description George R. Goffe 2018-11-14 17:29:03 UTC
Description of problem:

Attempt to start VirtualBox UI caused systemd to segfault. I have been unable to get the latest DEV version of VB to install... created bug report "https://www.virtualbox.org/ticket/18122"

Version-Release number of selected component (if applicable):

systemd-239-9.git9f3aed1.fc30.x86_64

How reproducible:

Only one time so far, newest version of VB fails to config. See bug report https://www.virtualbox.org/ticket/18122. corefile available.

Steps to Reproduce:
1.Start VirtualBox
2.
3.

Actual results:

Segfault in systemd with corefile.


Expected results:


Additional info:

gdb core.systemd.*
GNU gdb (GDB) Fedora 8.2.50.20181016-7.fc30
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
[New LWP 291430]
Reading symbols from /usr/lib/systemd/systemd...
Reading symbols from /usr/lib/debug/usr/lib/systemd/systemd-239-9.git9f3aed1.fc30.x86_64.debug...

warning: Ignoring non-absolute filename: <linux-vdso.so.1>
Missing separate debuginfo for linux-vdso.so.1
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/7a/c0141caad08eb301b51445e4ebb822b7d74a44
Missing separate debuginfo for /lib64/libpam.so.0
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/ff/10dc2ac056d702a81edbfb645244c3a257f0e1
Missing separate debuginfo for /lib64/libpthread.so.0
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/06/a3372239fabcf8a31de29f5de6bc625680b546
Missing separate debuginfo for /lib64/libc.so.6
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/8f/153aec47b4588f01e1ecebcfbe24091247bb60
Missing separate debuginfo for /lib64/ld-linux-x86-64.so.2
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/19/fc2e9ee99343b7905b2e816e5bd307d0bc4ea5
Missing separate debuginfo for /lib64/libdl.so.2
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/31/6fe9b3115433de483689e6ce037b2ccb521575
Missing separate debuginfo for /lib64/libssl.so.1.1
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/c8/7cb7f4889d8e181a8ec5b247caefc640836be7
Missing separate debuginfo for /lib64/libcrypto.so.1.1
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/70/92f2889b51d70813281cc9e141b06821695b08
Missing separate debuginfo for /lib64/libm.so.6
Try: dnf --enablerepo='*debug*' install /usr/lib/debug/.build-id/51/d0a344a86e86744f419c0827383f873c5385cb

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments
[New LWP 1]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib64/libthread_db.so.1".

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments

warning: Loadable section ".note.gnu.property" outside of ELF segments
Core was generated by `/usr/lib/systemd/systemd --system --deserialize 44'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f40573d983b in kill () at ../sysdeps/unix/syscall-template.S:78
78      T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (LWP 291430)]
(gdb) where
#0  0x00007f40573d983b in kill () at ../sysdeps/unix/syscall-template.S:78
#1  0x0000561ad2d67eda in crash (sig=11) at ../src/core/main.c:183
#2  <signal handler called>
#3  __strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:152
#4  0x00007f4057868c27 in message_append_basic (m=0x561ad4dc6630, type=<optimized out>, p=0xffffffffffffffff, stored=0x0)
    at ../src/basic/string-util.h:36
#5  0x00007f405786b0e9 in sd_bus_message_appendv (m=0x561ad4dc6630, types=<optimized out>, types@entry=0x561ad2e11796 "uoss", 
    ap=ap@entry=0x7ffe0391f4d0) at ../src/libsystemd/sd-bus/bus-message.c:2363
#6  0x00007f405786b70d in sd_bus_message_append (m=<optimized out>, types=types@entry=0x561ad2e11796 "uoss")
    at ../src/libsystemd/sd-bus/bus-message.c:2478
#7  0x0000561ad2df6236 in send_removed_signal (bus=0x561ad4ce7650, userdata=0x561ad4bd0b00) at ../src/core/dbus-job.c:210
#8  0x0000561ad2d792df in bus_foreach_bus (m=0x561ad49d43b0, subscribed2=0x0, send_message=send_message@entry=0x561ad2df6190 <send_removed_signal>, 
    userdata=userdata@entry=0x561ad4bd0b00) at ../src/core/dbus.c:1187
#9  0x0000561ad2df6818 in bus_job_send_removed_signal (j=j@entry=0x561ad4bd0b00) at ../src/core/dbus-job.c:225
#10 0x0000561ad2daad58 in manager_flush_finished_jobs (m=<optimized out>) at ../src/core/manager.c:3400
#11 manager_reload (m=m@entry=0x561ad49d43b0) at ../src/core/manager.c:3518
#12 0x0000561ad2d63b42 in invoke_main_loop (ret_error_message=0x7ffe0391f6f8, ret_switch_root_init=<synthetic pointer>, 
    ret_switch_root_dir=<synthetic pointer>, ret_fds=0x7ffe0391f708, ret_shutdown_verb=<synthetic pointer>, ret_retval=<synthetic pointer>, 
    ret_reexecute=<synthetic pointer>, m=0x561ad49d43b0) at ../src/core/main.c:1661
#13 main (argc=<optimized out>, argv=0x7ffe0391f9d8) at ../src/core/main.c:2417
(gdb)

Comment 1 Zbigniew Jędrzejewski-Szmek 2018-11-14 21:56:18 UTC
Yeah, we're working on it.

*** This bug has been marked as a duplicate of bug 1648753 ***


Note You need to log in before you can comment on or make changes to this bug.