Bug 164995 - kernel-2.6.12-1.1372_FC3 on scsi-based PC reports Debug: sleeping function called from invalid context at mm/slab.c:2126 and hangs later
kernel-2.6.12-1.1372_FC3 on scsi-based PC reports Debug: sleeping function ca...
Status: CLOSED DUPLICATE of bug 144111
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 08:48 EDT by Robert Evans
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 01:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Evans 2005-08-03 08:48:34 EDT
Description of problem:
A system running kernel-2.6.12-1.1372_FC3 with a SCSI adaptor and disks reports
"Debug: sleeping function called from invalid context at mm/slab.c:2126"
at boot time. See "Additional Info" for full dump of error message.

Later (after a few hours) the system freezes and is non responsive
to console or network interactions so it has to be powered-off to
restart.

The system is a departmental mailserver and so has moderately heavy
network traffic and disk usage.

This bug is not seen on non-SCSI based systems. The bug was not present
in 2.6.11-1.35_FC3.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3
SELinux disabled.

How reproducible:
The PC hangs each time kernel 2.6.12-1.1372_FC3 is used within about 12 hours.


Steps to Reproduce:
1. Boot kernel 2.6.12-1.1372_FC3 on SCSI-based system
2. Run normally
3. Wait
  
Actual results:


Expected results:


Additional info:
Jul 22 16:47:42 portico kernel: SCSI subsystem initialized
Jul 22 16:47:42 portico netfs: Mounting other filesystems:  succeeded
Jul 22 16:47:42 portico kernel: ACPI: PCI Interrupt 0000:00:1f.2[A] -> Link
[LNKC] -> GSI 10 (level, low) -> IRQ 10
Jul 22 16:47:42 portico kernel: ata1: SATA max UDMA/133 cmd 0xE800 ctl 0xE402
bmdma 0xD800 irq 10
Jul 22 16:47:42 portico kernel: ata2: SATA max UDMA/133 cmd 0xE000 ctl 0xDC02
bmdma 0xD808 irq 10
Jul 22 16:47:42 portico kernel: ata1: SATA port has no device.
Jul 22 16:47:42 portico kernel: scsi0 : ata_piix
Jul 22 16:47:42 portico kernel: ata2: SATA port has no device.
Jul 22 16:47:42 portico kernel: scsi1 : ata_piix
Jul 22 16:47:42 portico kernel: ACPI: PCI Interrupt Link [LNKF] enabled at IRQ 11
Jul 22 16:47:42 portico kernel: PCI: setting IRQ 11 as level-triggered
Jul 22 16:47:42 portico kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link
[LNKF] -> GSI 11 (level, low) -> IRQ 11
Jul 22 16:47:42 portico kernel: sym0: <875> rev 0x4 at pci 0000:01:00.0 irq 11
Jul 22 16:47:42 portico kernel: sym0: Symbios NVRAM, ID 7, Fast-20, SE, parity
checking
Jul 22 16:47:42 portico kernel: sym0: open drain IRQ line driver, using on-chip SRAM
Jul 22 16:47:42 portico kernel: sym0: using LOAD/STORE-based firmware.
Jul 22 16:47:42 portico rc: Starting lm_sensors:  succeeded
Jul 22 16:47:42 portico kernel: sym0: SCSI BUS has been reset.
Jul 22 16:47:42 portico kernel: scsi2 : sym-2.2.0
Jul 22 16:47:42 portico kernel: logips2pp: Detected unknown logitech mouse model 1
Jul 22 16:47:42 portico kernel: input: ImPS/2 Logitech Wheel Mouse on isa0060/serio1
Jul 22 16:47:42 portico kernel:   Vendor: SEAGATE   Model: ST318453LW       
Rev: 0003
Jul 22 16:47:42 portico kernel:   Type:   Direct-Access                     
ANSI SCSI revision: 03
Jul 22 16:47:42 portico kernel:  target2:0:0: tagged command queuing enabled,
command queue depth 16.
Jul 22 16:47:42 portico kernel:  target2:0:0: Beginning Domain Validation
Jul 22 16:47:42 portico kernel: Debug: sleeping function called from invalid
context at mm/slab.c:2126
Jul 22 16:47:42 portico kernel: in_atomic():0, irqs_disabled():1
Jul 22 16:47:42 portico kernel:  [<c011d3a4>] __might_sleep+0x9c/0xaa
Jul 22 16:47:42 portico kernel:  [<c0159821>] __kmalloc+0x69/0x7a
Jul 22 16:47:42 portico kernel:  [<c015988a>] kcalloc+0x2b/0x52
Jul 22 16:47:42 portico kernel:  [<f8923217>] sym_alloc_lcb_tags+0x5c/0xf0
[sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<f8922c2e>] sym_get_ccb+0x231/0x2ab [sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<f884e21c>] __scsi_get_command+0x15/0x165
[scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f891ab21>] sym_queue_command+0x99/0xc4
[sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<f891aea4>] sym53c8xx_queue_command+0x49/0x75
[sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<f884ed67>] scsi_dispatch_cmd+0x1c3/0x43b
[scsi_mod]
Jul 22 16:47:42 portico kernel:  [<c0281c65>] elv_requeue_request+0x34/0x55
Jul 22 16:47:42 portico kernel:  [<c0281f0b>] elv_next_request+0x7e/0x141
Jul 22 16:47:42 portico kernel:  [<f8856a9f>] scsi_request_fn+0x237/0x7ef [scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f891a9f8>] sym_scatter+0x27/0xb7 [sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<c02853ee>] blk_insert_request+0x145/0x1f7
Jul 22 16:47:42 portico kernel:  [<f882e0b5>] spi_wait_req+0x38/0x6c
[scsi_transport_spi]
Jul 22 16:47:42 portico kernel:  [<c0121376>] vprintk+0x1cf/0x49d
Jul 22 16:47:42 portico kernel:  [<f882f1e9>]
spi_dv_device_compare_inquiry+0x99/0x108 [scsi_transport_spi]
Jul 22 16:47:42 portico kernel:  [<f882f51f>] spi_dv_device_internal+0x5b/0x2d8
[scsi_transport_spi]
Jul 22 16:47:42 portico kernel:  [<f882f863>] spi_dv_device+0xc7/0x13a
[scsi_transport_spi]
Jul 22 16:47:42 portico kernel:  [<f891b9f2>]
sym53c8xx_slave_configure+0xd1/0xd3 [sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<f88589b9>] scsi_add_lun+0x2f2/0x317 [scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f8858ab7>] scsi_probe_and_add_lun+0xd9/0x225
[scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f8859309>] scsi_scan_target+0xcb/0x13c [scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f88593f0>] scsi_scan_channel+0x76/0x88 [scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f8859486>] scsi_scan_host_selected+0x84/0xf4
[scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f8850073>] scsi_add_host+0xd3/0x1ce [scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f8859517>] scsi_scan_host+0x21/0x25 [scsi_mod]
Jul 22 16:47:42 portico kernel:  [<f891cf84>] sym2_probe+0xba/0xed [sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<c0210c8f>] pci_device_probe_static+0x30/0x43
Jul 22 16:47:42 portico kernel:  [<c0210cc4>] __pci_device_probe+0x22/0x33
Jul 22 16:47:42 portico kernel:  [<c0210cf0>] pci_device_probe+0x1b/0x32
Jul 22 16:47:42 portico kernel:  [<c027cedf>] driver_probe_device+0x21/0x55
Jul 22 16:47:42 portico kernel:  [<c027cff1>] driver_attach+0x46/0x85
Jul 22 16:47:42 portico kernel:  [<c0204ba8>] kobject_register+0x2e/0x59
Jul 22 16:47:42 portico kernel:  [<c027d405>] bus_add_driver+0x8a/0xb7
Jul 22 16:47:42 portico kernel:  [<c0210edb>] pci_register_driver+0x93/0xaa
Jul 22 16:47:42 portico kernel:  [<f8820028>] sym2_init+0x28/0x42 [sym53c8xx]
Jul 22 16:47:42 portico kernel:  [<c01463fe>] sys_init_module+0x132/0x1c1
Jul 22 16:47:42 portico kernel:  [<c0176643>] filp_close+0x3f/0x6f
Jul 22 16:47:42 portico kernel:  [<c010392d>] syscall_call+0x7/0xb
Jul 22 16:47:42 portico kernel:  target2:0:0: asynchronous.
Jul 22 16:47:42 portico kernel: WIDTH IS 1
Jul 22 16:47:42 portico kernel:  target2:0:0: wide asynchronous.
Jul 22 16:47:42 portico kernel:  target2:0:0: FAST-20 WIDE SCSI 40.0 MB/s ST (50
ns, offset 16)
Jul 22 16:47:42 portico kernel:  target2:0:0: Ending Domain Validation
Jul 22 16:47:42 portico kernel: SCSI device sda: 35843686 512-byte hdwr sectors
(18352 MB)
Jul 22 16:47:42 portico kernel: SCSI device sda: drive cache: write back
Jul 22 16:47:42 portico kernel: SCSI device sda: 35843686 512-byte hdwr sectors
(18352 MB)
Jul 22 16:47:42 portico kernel: SCSI device sda: drive cache: write back
Jul 22 16:47:42 portico kernel:  sda: sda1
Jul 22 16:47:42 portico kernel: Attached scsi disk sda at scsi2, channel 0, id
0, lun 0
Jul 22 16:47:42 portico kernel: device-mapper: 4.4.0-ioctl (2005-01-12)
initialised: dm-devel@redhat.com
Jul 22 16:47:42 portico kernel: kjournald starting.  Commit interval 5 seconds
Jul 22 16:47:42 portico kernel: EXT3-fs: mounted filesystem with ordered data mode.
Comment 1 Dan Carpenter 2005-08-04 00:47:06 EDT
this is the same as bug 144111

The kcalloc in sym_alloc_lcb_tags.

Comment 2 Dave Jones 2005-08-04 01:00:24 EDT

*** This bug has been marked as a duplicate of 144111 ***

Note You need to log in before you can comment on or make changes to this bug.