Bug 165004 - "plague-client build ..." succeeds, but request is not enqueued actually
"plague-client build ..." succeeds, but request is not enqueued actually
Status: CLOSED RAWHIDE
Product: Fedora Infrastructure
Classification: Retired
Component: extras buildsys (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 10:28 EDT by Michael Schwendt
Modified: 2007-04-18 13:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-11 14:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-08-03 10:28:06 EDT
$ make plague
/usr/bin/plague-client build sylpheed sylpheed-2_0_0-1 devel
Package sylpheed enqueued.

$ plague-client list | grep syl
$

$ plague-client list email bugs.michael@gmx.net | grep sylp
$

$ plague-client list email bugs.michael@gmx.net 
137: inkscape (inkscape-0_42-1_fc5)  bugs.michael@gmx.net   failed
        hammer3.fedora.redhat.com(x86_64):
fd8220e02c46059b741652237ce8d70904b11da8 done/failed
        hammer2.fedora.redhat.com(i386):
820ffdd3b16c96572bc477511037074e46a87696 done/killed

226: glunarclock (glunarclock-0_32_4-1_fc4)  bugs.michael@gmx.net   failed


Another try:

$ make plague
/usr/bin/plague-client build sylpheed sylpheed-2_0_0-1 devel
Package sylpheed enqueued.

$ plague-client list | grep syl
$
Comment 1 Ed Hill 2005-08-03 11:10:05 EDT
I'm seeing the same problem right now with nco.  I just ran:

  $ cd rpms/nco/FC-4
  $ make plague
  /usr/bin/plague-client build nco nco-3_0_1-4_fc4 fc4
  Package nco enqueued.

but the build doesn't start.  And waiting a half-hour and re-trying doesn't 
help.  The odd thing is that it worked just fine for me yesterday.
Comment 2 Jeremy Katz 2005-08-03 12:54:05 EDT
This is the failure case when the server gets wedged.

Probably one sane thing to do here is to have the client not get back a success
from the server until after the job is successfully committed to the jobdb. 
That at least gets rid of silent failures.

The second thing is fixing things so we don't end up in this state.

Adding dcbw to the cc list since he's spearheading most of the actual writing of
code.
Comment 3 Dan Williams 2005-08-11 14:00:43 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.