Bug 165016 - Left Win-key + some multimedia keys randomly stop responding
Left Win-key + some multimedia keys randomly stop responding
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 11:43 EDT by Øyvind Stegard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-06 22:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (11.00 KB, text/plain)
2005-08-03 11:45 EDT, Øyvind Stegard
no flags Details
lspci -vv (6.90 KB, text/plain)
2005-08-03 11:46 EDT, Øyvind Stegard
no flags Details
/etc/X11/xorg.conf (3.46 KB, text/plain)
2005-08-03 12:01 EDT, Øyvind Stegard
no flags Details
/var/log/Xorg.0.log (34.58 KB, text/plain)
2005-08-03 12:06 EDT, Øyvind Stegard
no flags Details

  None (edit)
Description Øyvind Stegard 2005-08-03 11:43:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The left "Windows" key (X keysym 'Super_L') on my laptop randomly stops responding. When this happens, no events at all are generated (tested with xev and showkeys). Also, the same things happens with two of my multimedia keys ("Music"-button, and "Information"-button). Sometimes they randomly start working again, I can see no pattern at all, and I don't know what causes it. It might just as well be a kernel bug, for all I know. None of the keys are physically damaged, of course. It's extremely annoying since I use the windows-key as a modifier for launching apps and doing window management operations. It started happening recently, although I am not quite sure which update might have caused it. Has never happened before.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1398_FC4
xorg-x11-6.8.2-37

How reproducible:
Sometimes

Steps to Reproduce:
1. I do not know what causes it, but it basically happens after a couple of hours of X use.
2. Sorry, I really have no idea how to forcefully reproduce it, but it happens often.

  

Actual Results:  The affected keys suddenly stop generating keyboard input events. 

Expected Results:  Key(s) should work all the time.

Additional info:

No dmesg output of interest. Nothing of interest in /var/log/messages. However, I am occasionally getting "SetGrabKeysState enable" and "SetGrabKeysState disable" at the end of /var/log/Xorg.0.log. 
As mentiond, xev and showkeys show nothing when I press the misbehaving keys, after the problem has appeared. I use no xmodmap tweaks, or anything of that kind. Only Gnome keyboard preferences and system-config-keyboard.

Right win-key works normally all the time.

Some version numbers:
kernel-2.6.12-1.1398_FC4
xorg-x11-6.8.2-37
libgcc-4.0.1-4.fc4
glibc-2.3.5-10.2

Hardware:
Compaq Presario 920EA (European) laptop, Norwegian keyboard layout.
dmesg  (attached, output is from a self-compiled rawhide kernel, but the problem is still there, and it definitely occurs in kernel-2.6.12-1.1398_FC4, as well.)

lspci -vv (attached)
Comment 1 Øyvind Stegard 2005-08-03 11:45:57 EDT
Created attachment 117410 [details]
dmesg
Comment 2 Øyvind Stegard 2005-08-03 11:46:30 EDT
Created attachment 117411 [details]
lspci -vv
Comment 3 Øyvind Stegard 2005-08-03 12:01:59 EDT
Created attachment 117414 [details]
/etc/X11/xorg.conf
Comment 4 Øyvind Stegard 2005-08-03 12:06:35 EDT
Created attachment 117416 [details]
/var/log/Xorg.0.log
Comment 5 Øyvind Stegard 2005-08-06 14:56:14 EDT
I've now found a way to re-enable the Win-key after it's dead: I have to plug in
an external keyboard (so that I have two active keyboards) and press its
Win-key. Voila, the notebook Win-key starts generating events again. Now, after
I unplug the external keyboard, the key continues to work, until the problem
happens again. I do not know whether Xorg is to blame, or the kernel. But I've
seen reports of keyboard problems with newer kernels. If more information is
required, please let me know. I'll continue to hunt for what causes the key to
stop responding. But, as I've stated earlier, I can at this time see no patterns
(it's very erratic).
Comment 6 Øyvind Stegard 2005-08-06 15:05:56 EDT
OK, forget what I said in comment #5, it was only a coincidence. The key just
happened to start working after I had plugged in the external keyboard. Not
reproducible. 8(. Still having difficulties.
Comment 7 Øyvind Stegard 2005-08-06 18:30:25 EDT
I am pretty sure that this is a kernel bug, and not xorg (but xorg might be
triggering it, or it might be a nice combination of the two). I can boot to
runlevel 1, and still, 'showkey' tells me that the key is not generating an
event (soft reboot). I've also confirmed the same thing by using the evbug
module, when the problem is there. I managed to get the key working again, by
pulling out and re-inserting my wireless PCMCIA card. Strange, perhaps it's
another one of those lovely ACPI bugs (my laptop won't boot with acpi=off, so
that remains untested). Tried all sorts of i8042.* boot options (including
i8042.noacpi, also atkbd.reset), but none of them helped. I am changing bug
component from xorg to kernel.
Comment 8 Øyvind Stegard 2005-08-06 22:44:20 EDT
As it turns out, my keyboard is dying on me. I started thinking about what might
be triggering it, and suddenly realized I was always doing something
physical(other than staring at the screen & typing) with the laptop at times
when I got it working. Pulling and and re-inserting a PCMCIA card, turning it
around to insert external keyboard, pressing keys in pure frustration=). Finally
a pattern in the madness. I found a magic pressure point to get it working, so
there's a bad connector somewhere inside the keyboard, dammit. Extremely
sensitive stuff. Time to start using the other Win-key now, I guess. Well,
anyways, sorry to those who might have paid attention to the "bug"-report,
forget about it. Hope I didn't waste anybody's time.

NOT A BUG =).

Note You need to log in before you can comment on or make changes to this bug.