Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1650173 - broken deps for fence-agents on F29
Summary: broken deps for fence-agents on F29
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fence-agents
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Oyvind Albrigtsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-15 14:14 UTC by Michael Mráka
Modified: 2019-01-08 10:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-08 10:49:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Mráka 2018-11-15 14:14:55 UTC
Description of problem:
fence-agents-all can't be installed due to broken dependecies.

Version-Release number of selected component (if applicable):
fence-agents-all-4.3.0-1.fc29.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf install fence-agents-all
2.
3.

Actual results:
# dnf install fence-agents-all 
Last metadata expiration check: 1:01:06 ago on Thu Nov 15 13:08:44 2018.
Error: 
 Problem: conflicting requests
  - package fence-agents-all-4.3.0-1.fc29.noarch requires fence-agents-sbd, but none of the providers can be installed
  - package fence-agents-all-4.2.1-6.fc29.noarch requires fence-agents-sbd, but none of the providers can be installed
  - package fence-agents-sbd-4.3.0-1.fc29.noarch requires sbd, but none of the providers can be installed
  - package fence-agents-sbd-4.2.1-6.fc29.noarch requires sbd, but none of the providers can be installed
  - nothing provides libcib.so.4()(64bit) needed by sbd-1.2.1-4.fc28.1.x86_64


Expected results:
package installed

Additional info:
pacemaker-libs.x86_64 which contains libcib.so has been rebased from 1.1.18 to 2.0.0 and now contains libcib.so.27 (not libcib.so.4).

Comment 1 Oyvind Albrigtsen 2019-01-08 10:49:07 UTC
Fixed by new sbd build: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cafed1ee4f


Note You need to log in before you can comment on or make changes to this bug.