Bug 165039 - GDB intermittently fails with gcj-generated (BC-ABI) .sos.
GDB intermittently fails with gcj-generated (BC-ABI) .sos.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On: 165025
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 15:22 EDT by Andrew Cagney
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.0.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 03:57:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2005-08-03 15:22:12 EDT
+++ This bug was initially created as a clone of Bug #165025 +++

Description of problem:
GDB intermittently fails with gcj-generated (BC-ABI) .sos.

Version-Release number of selected component (if applicable):
gdb-6.3.0.0-1.24.ppc

How reproducible:
Always ... although no small test case unfortunately.

Steps to Reproduce:
1. start eclipse
2. gdb /usr/bin/java <pid>
3. thread apply all bt (or almost any command ... it happens quite frequently)
  
Actual results:
../../gdb-6.3/gdb/dwarf2-frame.c:454: internal-error: Unknown CFI 47 encountered.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) y
../../gdb-6.3/gdb/dwarf2-frame.c:454: internal-error: Unknown CFI 47 encountered.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Create a core file of GDB? (y or n) n

Expected results:
No gdb failures.

Additional info:
Andrew Cagney has looked into this and knows what the problem is.
Comment 1 Andrew Cagney 2005-08-03 15:25:43 EDT
[is there a gcj category?]

GCJ (libffi) needs to be updated to use DW_CFA_offset_extended_sf instead of
DW_CFA_GNU_negative_offset_extended.

libffi/src/powerpc/sysv.S:172:      .byte     0x2f     /* 
DW_CFA_GNU_negative_offset_extended */
libffi/src/powerpc/ppc_closure.S:244:   .byte   0x2f     #
DW_CFA_GNU_negative_offset_extended
Comment 2 Jakub Jelinek 2005-08-06 05:34:11 EDT
I'll change this.  On the other side, GDB really should handle
DW_CFA_GNU_negative_offset_extended, as there are plenty of binaries/libraries
still using them.
Comment 4 Andrew Cagney 2005-08-09 10:35:10 EDT
(In reply to comment #2)
> On the other side, GDB really should handle
> DW_CFA_GNU_negative_offset_extended, as there are plenty of binaries/libraries
> still using them.

That's why I cloned the bug, I've got the patch for the GDB side pending.

Note You need to log in before you can comment on or make changes to this bug.