Bug 165064 - nfsv4 kernel error on RHEL 4: xdr error 10008
nfsv4 kernel error on RHEL 4: xdr error 10008
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On: 142813
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-08-03 20:26 EDT by Steve Dickson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-727
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:46:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2005-08-03 20:26:05 EDT
+++ This bug was initially created as a clone of Bug #142813 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
when trying to mount a nfs4 filesystem on another remote fedora core 3
(FC3), i got the following error repeated on the client syslog :
Dec 10 15:46:27 filer2 kernel: decode_getfattr: xdr error 10008!
Dec 10 15:46:43 filer2 kernel: decode_getfattr: xdr error 10008!

... while the mount command seems to be "freezed" (but interruptible
by ^C). So any of my attempts to mount with nfs4 failed.

Here is the config on both nodes:
kernel 2.6.9 compiled from tarballs from kernel.org, all nfs option
compiled-in the kernel itself.
Fedora Core 3 with unmodified tools (FC3 seems to natively support nfs4)
both portmaps on client and server listen only to localhost
(vanemery's doc allow access to portmap only to localhost, so i think
it does the same)

Server: nfs export of a XFS partition
$ cat /etc/exports
/vol/0/nfsroot  10.0.0.0/24(ro,fsid=0,insecure,no_subtree_check,sync)

The mount command on the client was:
mount -t nfs4 -o ro,intr 10.0.0.58:/ /home/

i used the AUTH_SYS method described step by step on the vanemery tutorial
(http://www.vanemery.com/Linux/NFSv4/NFSv4-no-rpcsec.html)
except the "acl" mount option because xfs doesn't accept it. (i think
xfs supports ACLs natively)

anyone has an idea about the "xdr error 10008" error ?

Thanks in advance, 

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Mount an nfsv4 filesystem
2.
3.
    

Additional info:
Comment 1 Steve Dickson 2005-08-03 20:31:13 EDT
Fixed in nfs-utils-1.0.6-57
Comment 4 Anthony Messina 2005-09-04 17:37:15 EDT
(In reply to comment #1)
> Fixed in nfs-utils-1.0.6-57

When will this be released on RHN?  Their latest version of nfs-utils is 1.0.6-46.
Comment 9 Red Hat Bugzilla 2005-10-05 13:32:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-727.html
Comment 10 Red Hat Bugzilla 2005-10-05 13:46:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-727.html

Note You need to log in before you can comment on or make changes to this bug.