Bug 1650640 - roles & addons compliance mismatch in rules
Summary: roles & addons compliance mismatch in rules
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2.3
Assignee: Nikos Moumoulidis
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1650635
Blocks: 1650638
TreeView+ depends on / blocked
 
Reported: 2018-11-16 17:03 UTC by Nikos Moumoulidis
Modified: 2018-11-22 18:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1650635
Environment:
Last Closed: 2018-11-22 18:13:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin candlepin pull 2155 None None None 2018-11-19 18:07:37 UTC

Description Nikos Moumoulidis 2018-11-16 17:03:25 UTC
+++ This bug was initially created as a clone of Bug #1650635 +++

Description of problem:
The consumer's compliance is calculated wrong when the pool he is attached to, and which has at least one addon in common with the ones he specified, supports more than 1 addon.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:

- Have a consumer with installed product "product1" and set syspurpose addons to "addon1" and "addon2".
- Attach directly to a pool which provides product1, which has its addons product attribute set to "addon3,addon1"
- Query the consumer's compliance (not the syspurpose compliance, but the general one).


Actual results:
The compliance returned has status 'partial', and has 1 item in 'partiallyCompliantProducts' and 1 item in 'reasons'.

Expected results:

The compliance returned should have status 'valid', and should have no 'partiallyCompliantProducts' or 'reasons', since the pool supports at least one of the addons that the consumer has specified (addon1).

Additional info:

One additional problem: the rules look for the product attribute named 'role' instead of the proper one which is 'roles'.


Note You need to log in before you can comment on or make changes to this bug.