Bug 165066 - Starting rpc.svcgssd in nfs init script makes rpcsvcgssd init unnecessary?
Starting rpc.svcgssd in nfs init script makes rpcsvcgssd init unnecessary?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On: 160570
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-08-03 20:45 EDT by Steve Dickson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-727
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2005-08-03 20:45:21 EDT
+++ This bug was initially created as a clone of Bug #160570 +++

Description of problem:
According to the changelog in nfs-utils-1.0.6-52 the developer
"Changed the nfs.init script to bring rpc.svcgssd up and down,
  since rpc.svcgssd is only needed with the NFS server is running."

However the rpcsvcgssd init script is still added via chkconfig during install
*and* is started before nfs. Is this a mistake, or is there a reason the
rpcsvcgssd continues to be started through its own init script? 

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-52
but this also persists through latest fc4 version nfs-utils-1.0.7-8


How reproducible:

Install nfs-utils.  rpcsvcgssd persists in chkconfig as a startable service 
even if nfs is not started, or before nfs starts.


Steps to Reproduce:
1. install nfs-utils-1.0.6-52 or later

  
Actual results:

rpcsvcgssd is added to chkconfig as seperate service, and is started 
via nfs init script


Expected results:

start rpcsvcgssd in nfs init script only?

Additional info:
Comment 1 Steve Dickson 2005-08-03 20:47:37 EDT
Fixed in nfs-utils-1.0.6-58
Comment 7 Red Hat Bugzilla 2005-10-05 13:32:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-727.html
Comment 8 Red Hat Bugzilla 2005-10-05 13:46:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-727.html

Note You need to log in before you can comment on or make changes to this bug.