Bug 1651 - RPM doesn't work in Red Hat 5.9
Summary: RPM doesn't work in Red Hat 5.9
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-21 19:10 UTC by terminat
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-21 23:15:55 UTC


Attachments (Terms of Use)

Description terminat 1999-03-21 19:10:21 UTC
Just installed 5.9.  The rpm doesn't work.  Gives error
needs files /usr/lib/rpm/rpmrc.  This is clean install.
Corrected error by coping old rpm files to the new install.

Comment 1 Jeff Johnson 1999-03-21 21:38:59 UTC
Running "rpm -qlp" on the Red Hat 5.9 rpm-2.92-10.i386.rpm
indicates that /usr/lib/rpm/rpmrc is in the package.
Try reinstalling rpm and rpm-devel (using --force if necessary)
and reopen this bug if /usr/lib/rpm/rpmrc is not installed.

Comment 2 terminat 1999-03-21 21:55:59 UTC
If I do a rpm -Uvh rpm-2.92-10.i386.rpm I get the error "unpacking of
archive failed: cpio: Bad magic"  The devel goes in fine.

Comment 3 Jeff Johnson 1999-03-21 23:15:59 UTC
You have a corrupt rpm image. I have just verified that a (the?)
Red Hat 5.9 CD image of rpm-2.92-10 works, as in
	rpm -U --force rpm-2.92-10.i386.rpm


Note You need to log in before you can comment on or make changes to this bug.