Bug 1651546 - Lmod upgrade to version 7.8
Summary: Lmod upgrade to version 7.8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: Lmod
Version: epel7
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 10:18 UTC by Ole Holm Nielsen
Modified: 2019-02-20 00:51 UTC (History)
4 users (show)

Fixed In Version: Lmod-7.8.16-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-20 00:51:31 UTC


Attachments (Terms of Use)

Description Ole Holm Nielsen 2018-11-20 10:18:31 UTC
Description of problem:
The EasyBuild developers would like to use a recent version of Lmod, as discussed in this thread: https://lists.ugent.be/wws/arc/easybuild/2018-09/msg00021.html
Lmod version 7 contains important functionality enhancements and bug fixes as described in https://github.com/TACC/Lmod, and a number of software modules system administration methods depend on newer features in Lmod. 

Version-Release number of selected component (if applicable):
6.6.3

How reproducible:
Always

Steps to Reproduce:
1. rpm -q Lmod

Actual results:
Lmod-6.6.3-1.el7.x86_64

Expected results:
The latest Lmod version 7.8 is desired.

Additional info:
The current version 6.6.3 was updated in bug 1633929.
FC29 currently has a recent version Lmod-7.7.35-2.fc29.x86_64.
An update of Lmod in EPEL 7 would make life a lot easier for a large community using Lmod in combination with EasyBuild!

Comment 1 Loris Bennett 2019-01-23 11:16:36 UTC
I second this request.  In particular, version 6.6.3 does not allow for flexible hiding of modules.  Since, by design, EasyBuild generates modules for all the dependencies of a given piece of software, the complete list of available modules can become quite long.  Thus, for users who just want to run the main installed applications, it is highly desirable to be able to hide such dependencies.  This feature only appeared in Lmod 7.

Comment 2 Adam Huffman 2019-01-25 18:15:54 UTC
Yes, a lot of sites are currently having to build newer Lmod releases themselves because the EPEL package is so far behind.
Hence an update would be very welcome.

Comment 3 Fedora Update System 2019-02-03 00:39:16 UTC
Lmod-7.8.16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-0c078a6c4d

Comment 4 Fedora Update System 2019-02-05 02:04:40 UTC
Lmod-7.8.16-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-0c078a6c4d

Comment 5 Fedora Update System 2019-02-20 00:51:31 UTC
Lmod-7.8.16-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.