Bug 165161 - evince shows just a blank page
evince shows just a blank page
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-04 15:31 EDT by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 22:35:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A PDF that evince renders as a blank document (781.36 KB, application/pdf)
2005-08-12 19:26 EDT, W. Michael Petullo
no flags Details
A PDF file that evince doesn't show (835.53 KB, application/octet-stream)
2005-09-16 22:27 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2005-08-04 15:31:35 EDT
Description of problem:
When looking at the Haskell tutorial in PDF
<http://www.haskell.org/tutorial/haskell-98-tutorial.pdf> evince shows just
blank pages. xpdf-3.00-21 renders it fine.

Version-Release number of selected component (if applicable):
evince-0.3.1-2

How reproducible:
Looked only at this page

Steps to Reproduce:
1. Get <http://www.haskell.org/tutorial/haskell-98-tutorial.pdf>
2. evince haskell-98-tutorial.pdf
3.
  
Actual results:
Blank pages

Expected results:
Text (as shown by xpdf)

Additional info:
Dumb question: Should I attach the (largeish) PDF file, or is a link OK?
Comment 1 W. Michael Petullo 2005-08-12 19:26:25 EDT
Created attachment 117702 [details]
A PDF that evince renders as a blank document

Evicen does not render this PDF properly.  After a period of high CPU usage,
evince continues to display a blank, nine-page document.  This is a Red Hat
document.  I am using evince-0.3.2-2 and poppler-0.3.3-1.
Comment 2 W. Michael Petullo 2005-08-12 19:29:15 EDT
I this related to bug #160854?
Comment 3 Horst H. von Brand 2005-09-16 22:22:00 EDT
Still present in evince-0.4.0-2
Comment 4 Horst H. von Brand 2005-09-16 22:27:10 EDT
Created attachment 118924 [details]
A PDF file that evince doesn't show
Comment 5 W. Michael Petullo 2005-12-26 20:58:56 EST
evince-0.4.0-3.1 and poppler-0.4.2-1 display the document provided in comment #1
okay.  The upgrade fixed my problem.
Comment 6 Horst H. von Brand 2005-12-27 13:59:34 EST
evince-0.4.0-3.1 poppler-0.4.2-1 don't show the Haskell manual (<a
href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165161#c4">comment
#4</a>). I have since stumbled upon another, smaller one, but that I can't share :-(
Comment 7 Horst H. von Brand 2006-03-09 14:45:08 EST
evince-0.5.1-3: Works, in that it shows "something", but said "something" is in
a completely unreadable font.

Besides, I'm getting:

(evince:4414): libgnomevfs-WARNING **: Cannot load module  
`/usr/lib/gnome-vfs-2.0/modules/libcdda.so'  
(/usr/lib/gnome-vfs-2.0/modules/libcdda.so: cannot open shared object file: No
such file or directory)
Comment 8 W. Michael Petullo 2006-03-20 08:44:06 EST
The files provided seem to load for me.  However, they take several minutes to
render.
Comment 9 W. Michael Petullo 2006-03-20 08:44:40 EST
The files provided seem to load for me.  However, they take several minutes to
render.

I'm using:

poppler-0.5.1-2
evince-0.5.1-3
Comment 10 Oisin C. Feeley 2006-04-28 20:14:57 EDT
Well, the PDF provided does NOT render properly for me after 8 minutes on an
otherwise unburdened 1.5Ghz, 512Mb RAM maching and I'm also using

poppler-0.5.1-2
evince-0.5.1-3

What I see is 3 partially renedered pages which are practically unreadable due
to the fonts being skeletal and incomplete.  What do you see?
Comment 11 Horst H. von Brand 2006-09-14 20:06:25 EDT
Now I see something (almost unreadable due to fonts that look like shot at
repeatedly) for the Haskell tutorial in the original report. The document in
comment #1 shows fine. They don't take an inordinate ammount of time either.

evince-0.6.0-1.fc6
poppler-0.5.3-2.fc6
Comment 12 Horst H. von Brand 2007-07-17 09:42:33 EDT
As of evince-0.9.2-1.fc8, poppler-0.5.9-1.fc8 there are no changes WRT comment #11
Comment 13 Horst H. von Brand 2007-09-18 21:45:40 EDT
As of evince-2.20.0-1.fc8, poppler-0.6-1.fc8: Both documents mentioned above now
show fine. Should this now be closed?
Comment 14 Matthias Clasen 2007-09-18 22:35:29 EDT
If the documents render ok, then yes, lets close this.

Note You need to log in before you can comment on or make changes to this bug.