Bug 165193 - [RHEL-4] gnome-pty-helper doesn't clean up gnome-terminals' utmp/wtmp entries when killed
Summary: [RHEL-4] gnome-pty-helper doesn't clean up gnome-terminals' utmp/wtmp entries...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vte (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-05 08:27 UTC by Bastien Nocera
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0219
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:14:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vte-0.11.11-pty-helper-utmp-update.patch (1.44 KB, patch)
2006-12-19 11:24 UTC, Bastien Nocera
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0219 normal SHIPPED_LIVE vte bug fix update 2007-05-01 17:14:00 UTC

Description Bastien Nocera 2005-08-05 08:27:04 UTC
+++ This bug was initially created as a clone of Bug #159363 +++

Description of problem:
The utmp entries of gnome-terminals run under vnc don't get cleaned up if the
vnc session is killed via 'vncserver -kill <display>'. This is because vncserver
doesn't just kill the gnome-terminals as a user would, but rather kills all
child processes, which includes gnome-pty-helper. gnome-pty-helper just dies,
leaving the stale utmp/wtmp entries to potentially confuse subsequent users of
'/bin/who -u', which isn't supposed to show entries for dead processes.

Version-Release number of selected component (if applicable):
vte-0.11.10-11

How reproducible:
Always

Steps to Reproduce:
(This occurs naturally when a vncserver running gnome-terminals is killed using
'vncserver -kill <display number>' but the below process is much simpler)
1. start a gnome-terminal (note the tty)
2. kill both the gnome-terminal and gnome-pty-helper with SIGHUP
3. check 'who -u' output
  
Actual results:
The entry for the gnome-terminal is still there although the terminal is gone

Expected results:
No 'who -u' output for dead gnome-terminal

Additional info:
I've seen the gnome-terminal get SIGPIPE and as a result send SIGTERM to
gnome-pty-helper and I've also seen gnome-pty-helper get SIGHUP from (I guess)
vncserver.

Patch from Dave Lehman <dlehman@redhat.com> at:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=115067

Comment 1 Bastien Nocera 2005-08-05 08:28:04 UTC
Patch was committed to HEAD upstream.

Comment 9 Bastien Nocera 2006-04-03 10:32:46 UTC
The original patch was broken (ie. doing nasty things in the signal handler).
This upstream patch (on top of the old one) should fix it:
http://cvs.gnome.org/viewcvs/vte/gnome-pty-helper/gnome-pty-helper.c?r1=1.9&r2=1.10

Ray, let me know if you need the final patch backported.

Comment 10 Behdad Esfahbod 2006-07-27 21:36:06 UTC
Bastien, can you attach a final patch?

Comment 12 RHEL Product and Program Management 2006-08-18 17:28:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 13 Bastien Nocera 2006-12-19 11:24:21 UTC
Created attachment 143990 [details]
vte-0.11.11-pty-helper-utmp-update.patch

Untested patch.

Comment 14 Bastien Nocera 2006-12-19 11:30:30 UTC
I also included the patch from:
http://bugzilla.gnome.org/show_bug.cgi?id=387482

Patch compiles fine.

Comment 18 Behdad Esfahbod 2006-12-20 18:53:49 UTC
Built.

Comment 24 Red Hat Bugzilla 2007-05-01 17:14:02 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0219.html



Note You need to log in before you can comment on or make changes to this bug.