This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165198 - pppd capi plugin fails to load libcapi20
pppd capi plugin fails to load libcapi20
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: isdn4k-utils (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 05:34 EDT by David Woodhouse
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 10:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-08-05 05:34:04 EDT
Attempting to use the capiplugin results in the following error:

Couldn't load shared library libcapi20.so
libcapi20.so: cannot open shared object file: No such file or directory
Segmentation fault

Symlinking libcapi20.so -> libcapi20.so.3 makes it work.

You also need to remove /dev/capi20 (the 20th capi tty device) and recreate the
/dev/capi20 control device (major 68, minor 0).
Comment 1 Christoph Wickert 2006-03-03 22:06:40 EST
(In reply to comment #0)
> Attempting to use the capiplugin results in the following error:
> 
> Couldn't load shared library libcapi20.so
> libcapi20.so: cannot open shared object file: No such file or directory
> Segmentation fault
> 
> Symlinking libcapi20.so -> libcapi20.so.3 makes it work.

looks like a packagin bug to me:
# rpm -qf libcapi20.so
isdn4k-utils-devel-3.2-28
 
> You also need to remove /dev/capi20 (the 20th capi tty device) and recreate the
> /dev/capi20 control device (major 68, minor 0).

this is an udev issue, see bug #139321
Comment 2 Ngo Than 2006-03-10 10:59:46 EST
it's now fixed in isdn4k-utils-3.2-41 (rawhide). Thanks for your report.  

Note You need to log in before you can comment on or make changes to this bug.