Bug 165214 - gulm clients unable to mount -- lock_gulmd_LTPX xdr connection breaks
gulm clients unable to mount -- lock_gulmd_LTPX xdr connection breaks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gulm (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 10:59 EDT by Adam "mantis" Manthei
Modified: 2009-04-16 16:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: gulm-1.0.4-0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-10 15:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam "mantis" Manthei 2005-08-05 10:59:36 EDT
Description of problem:
Gulm clients are unalbe to mount the filesystem 

Version-Release number of selected component (if applicable):
GFS-kernel-2.6.9-36.2
GFS-6.1.2-0
gulm-devel-1.0.3-0
GFS-kernel-smp-2.6.9-36.2
GFS-kernheaders-2.6.9-36.2
gulm-1.0.3-0

How reproducible:
every time

Steps to Reproduce:
1. try to mount
2. EOF on xdr -- node gets fenced

  
Actual results:
Aug  4 16:35:34 trin-02 kernel: lock_harness: no version for "struct_module"
found: kernel tainted.
Aug  4 16:35:34 trin-02 kernel: Lock_Harness 2.6.9-36.2 (built Jul 13 2005
16:35:55) installed
Aug  4 16:35:34 trin-02 kernel: GFS 2.6.9-36.2 (built Jul 13 2005 16:37:15)
installed
kernel: GFS: Trying to join cluster "lock_gulm", "mantis:sda2"
kernel: Gulm 2.6.9-36.2 (built Jul 13 2005 16:36:26) installed
lock_gulmd_LTPX[1832]: EOF on xdr 
   (trin-07.lab.msp.redhat.com::ffff:10.15.84.177 idx:2 fd:7) 
trin-02 lock_gulmd_LTPX[1832]: Errors trying to login to LT000: 
   (trin-07.lab.msp.redhat.com ::ffff:10.15.84.177) 1006:Not Allowed

Expected results:
clients should mount

Additional info:
Mike's gcc4 fixes may have broke this in the RHEL4 branch
Comment 1 Adam "mantis" Manthei 2005-08-05 11:38:26 EDT
Was this ever tested?  I think it may have broken things...
(http://sources.redhat.com/cgi-bin/cvsweb.cgi/cluster/gulm/src/xdr_base.c?rev=1.2.2.2&content-type=text/x-cvsweb-markup&cvsroot=cluster&only_with_tag=RHEL4)


Revision 1.2.2.2 / (download) - annotate - [select for diffs] , Thu Jul 14
18:24:43 2005 UTC (3 weeks ago) by cfeist
Branch: RHEL4
CVS Tags: gulm_1_0_4, gulm_1_0_3, gulm_1_0_2
Changes since 1.2.2.1: +9 -3 lines
Diff to previous 1.2.2.1 (colored) to branchpoint 1.2 (colored) next main 1.3
(colored)

Merged changes from STABLE branch to fix problem caused by gcc 4 fixes.
Comment 2 Chris Feist 2005-08-05 14:21:45 EDT
Initially corey found a problem in the RHEL4 branch (which I think is the
problem you're seeing above) which was thought to be caused by the change in the
STABLE branch not being merged with the RHEL4 branch.  The 1.0.3-0 package that
you tested did not have the fix in it.  The 1.0.4-0 package should have the
merge from STABLE fix in it.  For some reason it didn't make it into the 1.0.3-0
rpm, let me know if the 1.0.4-0 rpm works for you.
Comment 3 Adam "mantis" Manthei 2005-08-05 16:09:29 EDT
Good to know...  

I can't find the bug that should be marked a duplicate of.

I haven't been able to verify that it's fixed in 1.0.4 because my machine are
completely hosed by the latest update to my systems.
Comment 4 Adam "mantis" Manthei 2005-08-10 15:12:13 EDT
I can mount with the latest packages

[root]# rpm -qa | grep -iE "(gfs|gulm)"
GFS-6.1.2-0
GFS-kernel-2.6.9-37.0
gulm-1.0.4-0
gulm-devel-1.0.4-0
GFS-kernheaders-2.6.9-37.0
GFS-kernel-smp-2.6.9-37.0

Note You need to log in before you can comment on or make changes to this bug.