Bug 165286 - grub hangs after installation on SATA
grub hangs after installation on SATA
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Depends On:
  Show dependency treegraph
Reported: 2005-08-06 20:10 EDT by Akemi Yagi
Modified: 2008-04-03 22:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-03 22:15:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -vv (13.14 KB, text/plain)
2005-09-10 23:53 EDT, Chris Thomas
no flags Details
lspci -n (992 bytes, text/plain)
2005-09-10 23:54 EDT, Chris Thomas
no flags Details

  None (edit)
Description Akemi Yagi 2005-08-06 20:10:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Fedora/1.7.10-1.3.1

Description of problem:
I have been trying to install FC4 on a new machine without success. 

motherboard: DFI K8M800-MLVF (VIA VT8237 chipset)
single SATA drive: Seagate 250GB

The installtion process goes through without a hitch. But the system does not boot and gets stuck after grub stage1_5. I tried reinstalling by booting from the rescue CD and issuing commands (such as root hd(0,0) etc) at the grub prompt.  Writing to the MBR is apparently successful but the system still hangs at boot. A few things that might give us a clue:

(1) If I use an IDE drive, there is no problem.  So this is SATA-related.
(2) Attempt to install other versions of FC revealed that FC3 with lilo (but NOT grub) as the bootloader had no problem.

It seems to me that my hardware is one of those "rare" cases that grub may have trouble with as described somewhere on the RedHat site.

I have been using grub with no issues since it became the default bootloader for RedHat/Fedora.  This is the first time I had to use lilo to get the system going.  If lilo can do the work, there may be a way to make grub to work (so I hope).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC4 on a SATA drive on the DFI K8M800-MLVF motherboard.
2. Boot the system

Actual Results:  Hangs at grub stage1_5

Expected Results:  complete booting

Additional info:

May be related to bug# 162529 except I only use ext3.
Comment 1 Chris Thomas 2005-09-10 23:45:02 EDT
I have the same motherboard but my hard drive is a WD Raptor 74GB. I have the 
same problem. I even reported it in FC3. After they didn't fix this bug in 
FC4, I started to try other distro's like Gentoo and Ubutntu. I found out it 
is a Grub problem and not a distro problem. Any grub version above 0.94 will 
not work on my system. I will attach my lspci so people can see what chipset 
and stuff I have.
Comment 2 Chris Thomas 2005-09-10 23:53:42 EDT
Created attachment 118687 [details]
lspci -vv
Comment 3 Chris Thomas 2005-09-10 23:54:58 EDT
Created attachment 118688 [details]
lspci -n
Comment 4 Michael Richardson 2006-05-09 15:28:15 EDT
I installed FC5 on a machine with an 82801GR SATA drive.
It installed relatively okay (i had to use the GUI rather than serial console to
get LVM on top of raid). My /boot is not raided or LVM'ed. Two 250G SATA drives.

Upon reboot, the BIOS loads grub, I get no grub stage 1.5 messages, just beeps
from the computer. So, I don't know if this "hangs at boot"

sh-3.1# lspci
00:00.0 Host bridge: Intel Corporation E7230 Memory Controller Hub (rev 81)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface
Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GR/GH (ICH7 Family) Serial ATA
Storage Controllers cc=AHCI (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 PCI bridge: Intel Corporation 6702PXH PCI Express-to-PCI Bridge A (rev 09)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
Ethernet PCI Express (rev 11)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
Ethernet PCI Express (rev 11)
05:02.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
Comment 5 Michael Richardson 2006-05-18 17:33:38 EDT
I solved my problem: it seems that grub can't cope with the choice of which of
the 4 SATA ports that I used.

I had SATA1/2 and SATA3/4, and I think that I used SATA1/3 before.
I moved the drives to be in SATA1/2, and things went better.  I also told the
BIOS to stay in normal IDE (2 controllers: PATA+SATA) mode, which probably also

Conclusion: grub can't deal with more than 4 drives and/or more than 2 controllers.
Comment 6 Christian Iseli 2007-01-22 05:59:40 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 7 Akemi Yagi 2007-01-22 18:08:59 EST
I installed FC6 and found exactly the same problem.  Apparently, this is unique
to certain motherboards.  I think this bug report can be closed because it is
not really RedHat/Fedora specific.

Comment 8 petrosyan 2008-02-21 18:57:51 EST
Fedora Core 6 is not maintained anymore.

Can you reproduce this bug in Fedora 8?
Comment 9 Akemi Yagi 2008-02-21 19:27:45 EST
As stated in comment #7, this is not Fedora specific.  I have since installed
CentOS 5 but the problem persisted.  Please close the bug.

Comment 10 Bug Zapper 2008-04-03 22:00:05 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 Akemi Yagi 2008-04-03 22:15:07 EDT
As noted in comments #7 and #9, this is not Fedora specific.  

Note You need to log in before you can comment on or make changes to this bug.