Bug 165297 - radeon power saving for 2366-97G (ThinkPad T30p)
radeon power saving for 2366-97G (ThinkPad T30p)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 165295 165296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-07 03:30 EDT by Stephan Groß
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 00:52:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephan Groß 2005-08-07 03:30:30 EDT
Hello, 
 
I succesfully tried the radeon-backlight patch included in the FC4 kernel 
by enabling the radeon_force_sleep parameter in modprobe.conf. With this, the 
power drain script from thinkwiki.org says 
 
 Fr Aug  5 22:54:01 CEST 2005 
 before: 33310 mWh 
 after: 26150 mWh 
 diff: -7160 mWh 
 seconds: 30036 sec 
 result: -858 mW 
 Congratulations, your model seems NOT to be affected. 
 
Please add 
 
+       { 
+               /* Reported by Stephan Groß <st.gross@inf.tu-dresden.de> */ 
+               .ident = "IBM ThinkPad T30 (2366-97G)", 
+               .matches = { 
+                       DMI_MATCH(DMI_SYS_VENDOR, "IBM"), 
+                       DMI_MATCH(DMI_PRODUCT_NAME, "236697G"), 
+               }, 
+       }, 
 
to linux-2.6.11-radeon-backlight.patch. Thanks!
Comment 1 Stephan Groß 2005-08-07 07:43:35 EDT
*** Bug 165296 has been marked as a duplicate of this bug. ***
Comment 2 Stephan Groß 2005-08-07 07:44:31 EDT
*** Bug 165295 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2005-08-26 18:18:39 EDT
hmm, the patch also contains..

    /* Negative reports: */
    /* IBM thinkpad T30 2366 -> machine hangs
       Reported by: Jakob Schiotz <schiotz@fysik.dtu.dk> */


I've sent a mail to Jakob, hopefully he can shed some light on this.
Comment 4 Warren Togami 2005-08-26 18:28:59 EDT
Stephan did you try your laptop suspended with the radeon backlight thing
forced?  That is the true test whether it is safe on your system or not.  On my
laptop it brings down my power usage from about 900mW/h to 200mW/h.  Your test
results above look like you didn't test it with radeon backlight turned off.
Comment 5 schiotz 2005-09-01 02:53:37 EDT
Sorry about the late reply - I have been away.

If this is the same patch as in bug 3022 on the "official" kernel bug tracker
(http://bugzilla.kernel.org/show_bug.cgi?id=3022) then it works on my IBM T30. 
An earlier version of the patch caused the machine to crash, but later versions
of the patch works fine.  The comments in the patch on that site reflects this,
perhaps an old comment has survived in the Red Hat patch - or perhaps you still
use the defective patch.  The crashes had only occurred when I had the machine
docked in the docking station, so other people may not see it.

/Jakob
Comment 6 Stephan Groß 2005-09-01 05:31:40 EDT
(In reply to comment #4)  
> Stephan did you try your laptop suspended with the radeon backlight thing  
> forced?  That is the true test whether it is safe on your system or not.  
  
What do you mean with "radeon backlight thing forced"? I added the line   
  
options radeonfb radeon_force_sleep=1 mirror=1 mode_option="640x480-24@70"  
  
to my /etc/modprobe.conf and   
  
radeontool light off  
  
to my acpi scripts. Anything more I can do? Beside the results from the  
thinkwiki-script I can definitely attest that the patch works for me because  
my battery now lasts much longer than hardly one day when being suspended.  
Comment 7 Dave Jones 2005-09-23 20:15:15 EDT
patch added to cvs. will be in the next fc4-updates-testing kernel (and
tomorrows rawhide)
Comment 8 Fedora Update System 2005-09-29 23:11:49 EDT
From User-Agent: XML-RPC

kernel-2.6.13-1.1526_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.