Bug 165325 - PowerBook wide screen resolutions not supported
PowerBook wide screen resolutions not supported
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Reopened
: 183094 189437 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-07 18:30 EDT by Frank Arnold
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 16:13:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 151459 None None None Never

  None (edit)
Description Frank Arnold 2005-08-07 18:30:38 EDT
This report is somewhat related to #151459

When starting s-c-display I get no option for the native resolution of my
PowerBook. Searched and found the closed upstream bug. Searched further and
found, that in the meantime a patch with modelines was added to xorg-x11.
Started to test and got a result:

Added modelines to /usr/share/rhpl/extramodes and updated the laptop-modes patch
for xorg-x11:

# 1280x854 @ 60Hz (PowerBook 15in) hsync: 51.96kHz; pclk: 79.81 MHz
Modeline "1280x854"  79.81  1280 1296 1408 1536  854 855 858 866  -Hsync -Vsync

# 1440x900 @ 60Hz (PowerBook 17in) hsync: 54.7 kHz; pclk: 96.21 MHz
Modeline "1440x900"   96.21  1440 1504 1536 1760  900 903 906 912  -Hsync -Vsync

The latter one is a result of Google search:
http://lists.terrasoftsolutions.com/pipermail/yellowdog-general/2003-October/010307.html.

Now the resolution was available with s-c-display, but not when running with
--reconfig switch.

Finally added "1280x854" to XF86SupportedResolutions() in
/usr/lib/python2.4/site-packages/xf86config.py and got it working (1440x900 is
already listed there).

Would be nice to get this in.
Comment 1 Frank Arnold 2006-02-26 06:07:47 EST
*** Bug 183094 has been marked as a duplicate of this bug. ***
Comment 2 Frank Arnold 2006-04-20 01:23:32 EDT
*** Bug 189437 has been marked as a duplicate of this bug. ***
Comment 3 Adam Jackson 2006-09-20 17:34:13 EDT
This should be resolved in rawhide as of s-c-d 1.0.45-1 or later.  Please test
and reopen if this is still an issue for you.
Comment 4 Frank Arnold 2006-10-14 11:54:38 EDT
[frank@notebook ~]$ rpm -q system-config-display
system-config-display-1.0.45-1

Still not working.
The list now contains 1440x900, but not 1280x854.
With --reconfig I get the options 1280x800, 1152x768, 1024x768, 800x600, and
640x480.
Comment 5 Adam Jackson 2007-01-29 18:42:08 EST
Mmm, we should be listing the resolutions advertised by the X server.  What does
'xrandr -q' print?
Comment 6 Frank Arnold 2007-02-07 09:28:52 EST
The situation has improved.

Here's the output of 'xrandr -q' with up to date Rawhide:

 SZ:    Pixels          Physical       Refresh
*0   1280 x 854    ( 322mm x 221mm )  *60  
 1    640 x 350    ( 322mm x 221mm )   60  
 2    640 x 400    ( 322mm x 221mm )   60  
 3    720 x 400    ( 322mm x 221mm )   60  
 4    640 x 480    ( 322mm x 221mm )   60  
 5    800 x 600    ( 322mm x 221mm )   60  
 6   1024 x 768    ( 322mm x 221mm )   60  
 7    832 x 624    ( 322mm x 221mm )   60  
 8   1152 x 768    ( 322mm x 221mm )   60  
 9   1280 x 720    ( 322mm x 221mm )   60  
 10  1280 x 800    ( 322mm x 221mm )   60  
 11  1280 x 768    ( 322mm x 221mm )   60  
Current rotation - normal
Current reflection - none
Rotations possible - normal 
Reflections possible - none

The dropdown list now contains exactly these resolutions except the first one,
which is the native resolution.
Comment 7 Adam Jackson 2007-03-12 16:13:58 EDT
Alright, added 1280x854 and a few others to pyxf86config, which might help
matters.  Please try pyxf86config 0.3.33-1 and reopen if this is still an issue.

Thanks!
Comment 8 Robert Story 2007-04-17 18:48:03 EDT
I still have this issue with system-config-display-1.0.45-1 (FC6). I seem the
same xrandr output as above..

Note You need to log in before you can comment on or make changes to this bug.