Bug 165326 - Unable to access kerberized NFS using ADS
Unable to access kerberized NFS using ADS
Status: CLOSED DUPLICATE of bug 189900
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-07 18:33 EDT by Matthew Booth
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 09:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2005-08-07 18:33:34 EDT
Description of problem:
An nfs export has been successfully mounted with sec=krb5. Attempting to access
the mount as a user gives:

WARNING: Failed to create krb5 context for user with uid 3147 for server srv041

in /var/log/messages.

The user is able to access other kerberized services, such as samba. The KDC is
Microsoft ADS.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-59
krb5-libs-1.3.4-17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Export and mount a filesystem with krb5 authentication, using ADS
2. Access the filesystem in any way (eg cd /mnt)
  
Actual results:
WARNING: Failed to create krb5 context for user with uid 3147 for server srv041

Expected results:
Filesystem access
Comment 2 Jeff Layton 2007-07-16 09:00:49 EDT
This problem should be resolved in 4.5.

*** This bug has been marked as a duplicate of 189900 ***

Note You need to log in before you can comment on or make changes to this bug.