Bug 165330 - Eclipse platform complains about missing swt.gtk
Eclipse platform complains about missing swt.gtk
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
http://scorpion77.cjb.net/images/ecli...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-07 22:23 EDT by Jeroen Beerstra
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 13:12:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeroen Beerstra 2005-08-07 22:23:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); nl-NL; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
When I look at the configuration manager from within Eclipse, there are a number of errors related to packages that are part of Fedora Core 4(see screenshot url). One of them is this:

Plug-in "org.eclipse.swt.gtk" version "3.1.0" referenced by this feature is missing.

It seems to me this is an issue related to improperly build rpm's for x86_64, there are no such errors on FC4 i386.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.22

How reproducible:
Always

Steps to Reproduce:
1. Install Eclipse from rpms provided with Fedora Core 4
2. Start Eclipse
3. Verify your installation from within Eclipse
  

Actual Results:  See Description and / or screenshot url

Expected Results:  There shouldn't be any installation errors for packages Fedora provides when you click on 'help->software updates->manage configuration' from within Eclipse.

Additional info:

There are others issues on x86_64, one of is already reported as bug #159031.
Comment 1 Andrew Overholt 2005-08-24 10:49:27 EDT
I'm sorry I haven't had a chance to look at this yet.  I really *really* want to
get Eclipse 3.1 final out for FC4 but bug #151832 is stopping that.  When we get
that closer to being fixed and get some 3.1 packages built as FC4 update
candidates, we can see if these x86_64 issues are fixed.  In the mean time, you
could try the rawhide packages and see if they fix your issues.  If you don't
want to mix in some rawhide stuff, I'll understand and look at this as soon as I
get some free time.
Comment 2 Jeroen Beerstra 2005-08-24 11:34:42 EDT
Don't really understand why one problematic bug can prevent others from being
fixed, but I'm sure you'll have your reasons.

I do have a problem with installing rawhide packages. Apart from this bug and
some other minor problems, Eclipse does work. Haven't seen a single crash since
I started using the FC4 build, congrats for that (not kidding!), and I use it a lot.

Is there any way to install rawhide packages without overwriting my current
installation? 
Comment 3 Andrew Overholt 2005-08-24 13:56:40 EDT
(In reply to comment #2)
> Don't really understand why one problematic bug can prevent others from being
> fixed, but I'm sure you'll have your reasons.

I don't think it's fair to make people download multiple ~100MB updates until we
have a working 3.1 final set of RPMs.

> Is there any way to install rawhide packages without overwriting my current
> installation? 

Not really.  I'll look into this.
Comment 4 Andrew Overholt 2005-11-01 14:33:53 EST
Can you try the potential 3.1.1 update in updates-testing?

yum --enablerepo=updates-testing update eclipse-pde (or whatever)

Please let me know if this still happens for you.  If it does not (or if you
don't think it's that important), I will go ahead with that update for FC4.
Comment 5 Jeroen Beerstra 2005-11-03 17:55:03 EST
AMD64/biarch problems seem to be solved, however there was a new problem:

http://scorpion77.cjb.net/images/eclipse_config.png

Could not figure out what exactly was wrong, since properties->status told me
the feature was installed correctly??

Also I would like to add there also was a problem with eclipse-cdt, which is not
included in these updates.

So back to the old eclipse for now. 
Comment 6 Andrew Overholt 2005-11-03 22:50:51 EST
(In reply to comment #5)
> AMD64/biarch problems seem to be solved, however there was a new problem:
> 
> http://scorpion77.cjb.net/images/eclipse_config.png
> 
> Could not figure out what exactly was wrong, since properties->status told me
> the feature was installed correctly??

Do you have eclipse-rcp-devel installed?

> Also I would like to add there also was a problem with eclipse-cdt, which is not
> included in these updates.

I can't update eclipse-cdt until eclipse itself is out as an update.  It will
follow.
Comment 7 Jeroen Beerstra 2005-11-04 07:48:17 EST
(In reply to comment #6)
> Do you have eclipse-rcp-devel installed?
> 

No, just did an upgrade, apparently eclipse-rcp-devel does not get included that
way. I'll retry later this day with eclipse-rcp-devel included. It's a lot of
work to update eclipse and then downgrade to get my custom plugins to work again
... but I guess it's worth the trouble ;)

> > Also I would like to add there also was a problem with eclipse-cdt, which is not
> > included in these updates.
> 
> I can't update eclipse-cdt until eclipse itself is out as an update.  It will
> follow.
> 

Ah I see.
Comment 8 Jeroen Beerstra 2005-11-04 12:26:18 EST
Yes that worked. The problems related to amd64/biarch are gone now, both on
startup and within eclipse.

However there is this error when you launch eclipse from the terminal:

LoadPlugin: failed to initialize shared library
/usr/lib/openoffice.org2.0/program/libnpsoplugin.so
[/usr/lib/openoffice.org2.0/program/libnpsoplugin.so: kan gedeeld objektbestand
niet openen: Onbekend bestand of map]

Looks like a totally harmless problem to me, not even related to eclipse but
rather a problem with 64bit mozilla versus 32bit Ooo2.0.

I say go ahead with the update. It would be nice though if the other eclipse
packages for Fedora get updated too, since they don't seem to work with this update.
Comment 9 Andrew Overholt 2005-11-04 13:12:47 EST
(In reply to comment #8)
> Yes that worked. The problems related to amd64/biarch are gone now, both on
> startup and within eclipse.

Awesome.

> Looks like a totally harmless problem to me, not even related to eclipse but
> rather a problem with 64bit mozilla versus 32bit Ooo2.0.

Yeah, that seems unrelated (I hope).

> I say go ahead with the update. It would be nice though if the other eclipse
> packages for Fedora get updated too, since they don't seem to work with this
update.

Yeah, I'll update them soon.  I can't build them against the updated one until
it goes final, though.  I guess I'll push now :)

Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.