Bug 1653349 - legacy ironic commands fail
Summary: legacy ironic commands fail
Keywords:
Status: CLOSED DUPLICATE of bug 1602066
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 14.0 (Rocky)
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Bob Fournier
QA Contact: mlammon
URL:
Whiteboard:
: 1665703 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-26 15:43 UTC by Gregory Charot
Modified: 2019-02-07 18:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 18:44:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gregory Charot 2018-11-26 15:43:42 UTC
Description of problem:

Legacy ironic commands fail on the undercloud

Version-Release number of selected component (if applicable):

14

How reproducible:

Always

Steps to Reproduce:
1.
[stack@undercloud ~]$ source stackrc
(undercloud) [stack@undercloud ~]$ ironic --debug node-list
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
DEBUG (extension:189) found extension EntryPoint.parse('v2token = keystoneauth1.loading._plugins.identity.v2:Token')
DEBUG (extension:189) found extension EntryPoint.parse('none = keystoneauth1.loading._plugins.noauth:NoAuth')
DEBUG (extension:189) found extension EntryPoint.parse('v3oauth1 = keystoneauth1.extras.oauth1._loading:V3OAuth1')
DEBUG (extension:189) found extension EntryPoint.parse('admin_token = keystoneauth1.loading._plugins.admin_token:AdminToken')
DEBUG (extension:189) found extension EntryPoint.parse('v3oidcauthcode = keystoneauth1.loading._plugins.identity.v3:OpenIDConnectAuthorizationCode')
DEBUG (extension:189) found extension EntryPoint.parse('v2password = keystoneauth1.loading._plugins.identity.v2:Password')
DEBUG (extension:189) found extension EntryPoint.parse('v3samlpassword = keystoneauth1.extras._saml2._loading:Saml2Password')
DEBUG (extension:189) found extension EntryPoint.parse('v3password = keystoneauth1.loading._plugins.identity.v3:Password')
DEBUG (extension:189) found extension EntryPoint.parse('v3adfspassword = keystoneauth1.extras._saml2._loading:ADFSPassword')
DEBUG (extension:189) found extension EntryPoint.parse('v3oidcaccesstoken = keystoneauth1.loading._plugins.identity.v3:OpenIDConnectAccessToken')
DEBUG (extension:189) found extension EntryPoint.parse('v3oidcpassword = keystoneauth1.loading._plugins.identity.v3:OpenIDConnectPassword')
DEBUG (extension:189) found extension EntryPoint.parse('v3kerberos = keystoneauth1.extras.kerberos._loading:Kerberos')
DEBUG (extension:189) found extension EntryPoint.parse('token = keystoneauth1.loading._plugins.identity.generic:Token')
DEBUG (extension:189) found extension EntryPoint.parse('v3oidcclientcredentials = keystoneauth1.loading._plugins.identity.v3:OpenIDConnectClientCredentials')
DEBUG (extension:189) found extension EntryPoint.parse('v3tokenlessauth = keystoneauth1.loading._plugins.identity.v3:TokenlessAuth')
DEBUG (extension:189) found extension EntryPoint.parse('v3token = keystoneauth1.loading._plugins.identity.v3:Token')
DEBUG (extension:189) found extension EntryPoint.parse('v3totp = keystoneauth1.loading._plugins.identity.v3:TOTP')
DEBUG (extension:189) found extension EntryPoint.parse('v3applicationcredential = keystoneauth1.loading._plugins.identity.v3:ApplicationCredential')
DEBUG (extension:189) found extension EntryPoint.parse('password = keystoneauth1.loading._plugins.identity.generic:Password')
DEBUG (extension:189) found extension EntryPoint.parse('v3fedkerb = keystoneauth1.extras.kerberos._loading:MappedKerberos')
DEBUG (extension:189) found extension EntryPoint.parse('v1password = swiftclient.authv1:PasswordLoader')
DEBUG (extension:189) found extension EntryPoint.parse('noauth = cinderclient.contrib.noauth:CinderNoAuthLoader')
DEBUG (extension:189) found extension EntryPoint.parse('token_endpoint = openstackclient.api.auth_plugin:TokenEndpoint')
DEBUG (extension:189) found extension EntryPoint.parse('aodh-noauth = aodhclient.noauth:AodhNoAuthLoader')
DEBUG (extension:189) found extension EntryPoint.parse('gnocchi-basic = gnocchiclient.auth:GnocchiBasicLoader')
DEBUG (extension:189) found extension EntryPoint.parse('gnocchi-noauth = gnocchiclient.auth:GnocchiNoAuthLoader')
__init__() got an unexpected keyword argument 'cafile'
2.
3.

Actual results:

__init__() got an unexpected keyword argument 'cafile'

Expected results:

Ironic node list

Additional info:

Comment 1 Bob Fournier 2018-11-26 15:56:36 UTC
Please show the version of python2-ironicclient being used, see also: 
https://bugzilla.redhat.com/show_bug.cgi?id=1602066

In addition see:
https://bugs.launchpad.net/tripleo/+bug/1778847

Comment 2 Gregory Charot 2018-11-26 16:26:28 UTC
rpm -qa | grep ironic
python2-ironic-inspector-client-3.3.0-0.20180810080932.53bf4e8.el7ost.noarch
puppet-ironic-13.3.1-0.20181013115250.el7ost.noarch
python2-ironicclient-2.5.0-0.20180810135843.fb94fb8.el7ost.noarch

Look like the same issue as BZ 1602066.

Comment 3 Bob Fournier 2018-11-26 19:30:23 UTC
Greg - which puddle are you using?  I'm also see this on the 10-12 puddle:
DEBUG (extension:189) found extension EntryPoint.parse('gnocchi-basic = gnocchiclient.auth:GnocchiBasicLoader')
DEBUG (extension:189) found extension EntryPoint.parse('gnocchi-noauth = gnocchiclient.auth:GnocchiNoAuthLoader')
__init__() got an unexpected keyword argument 'cafile'


Seems to be an issue with gnocchi client.

(undercloud) [stack@undercloud ~]$ rpm -qa | grep gnocchi
python2-gnocchiclient-7.0.4-0.20180823073245.64814b9.el7ost.noarch
puppet-gnocchi-13.3.1-0.20181013121920.4b95b4b.el7ost.noarch

Comment 4 Gregory Charot 2018-11-26 23:06:00 UTC
using passed_phase2 puddle

rpm -qa | grep gnocchi
python2-gnocchiclient-7.0.4-0.20180823073245.64814b9.el7ost.noarch
puppet-gnocchi-13.3.1-0.20181013121920.4b95b4b.el7ost.noarch

Comment 5 Bob Fournier 2019-01-14 00:05:17 UTC
*** Bug 1665703 has been marked as a duplicate of this bug. ***

Comment 6 Bob Fournier 2019-02-07 18:44:46 UTC

*** This bug has been marked as a duplicate of bug 1602066 ***


Note You need to log in before you can comment on or make changes to this bug.