Bug 1653351 - Unable to install perl 5.24 due to freeradius conflicts
Summary: Unable to install perl 5.24 due to freeradius conflicts
Keywords:
Status: CLOSED DUPLICATE of bug 1648839
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: yum
Version: 8.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 8.0
Assignee: Jaroslav Mracek
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks: 1623566
TreeView+ depends on / blocked
 
Reported: 2018-11-26 15:44 UTC by Stephen Hobbs
Modified: 2019-06-11 19:53 UTC (History)
3 users (show)

Fixed In Version: libdnf-0.22.4-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 14:43:20 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Stephen Hobbs 2018-11-26 15:44:02 UTC
Description of problem:
Installing perl module 5.24 fails due to version conflicts with freeradius even though free radius is not installed.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 8 Beta

How reproducible: 100%


Steps to Reproduce:
1. Install RHEL 8
2. yum module install perl:5.24
3.

Actual results:

# yum module install perl:5.24
Updating Subscription Management repositories.
Updating Subscription Management repositories.
Last metadata expiration check: 0:01:08 ago on Wed 21 Nov 2018 09:00:12 AM EST.
Error: Problems in request:
broken groups or modules: perl:5.24

 Problem: module DBI:1.641:20180827111759:fbe42456-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - conflicting requests
  - module perl:5.26:20180618135756:9edba152-0.x86_64 conflicts with module(perl:5.24) provided by perl:5.24:20181002150812:ee766497-0.x86_64
  - module perl:5.24:20181002150812:ee766497-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:20180618135756:9edba152-0.x86_64
  - module freeradius:3.0:20181012204341:fbe42456-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - module DBI:1.641:20180827111759:082fdf2f-0.x86_64 requires module(perl:5.24), but none of the providers can be installed



Expected results:
perl 5.24 should be able to be installed

Additional info:
After disabling the freeradius module, perl 5.24 was able to be installed.  freeradius seems to require perl 5.26, however if freeradius is not in use, perl 5.24 should be able to be installed.

Comment 1 Jaroslav Mracek 2018-12-11 12:06:56 UTC
We redesign a modular solver (https://github.com/rpm-software-management/libdnf/pull/655). The change should allow that default streams now would be more easy to switch.

At the present time you can use --skip-broken option to enable perl:5.24 module anyway.

Comment 3 Karel Srot 2018-12-20 14:24:25 UTC
I did try to install perl:5.24 module on RHEL-8.0-20181218.0 but I am still getting a failure

# dnf module list perl
Last metadata expiration check: 0:05:10 ago on Thu 20 Dec 2018 09:16:03 AM EST.
rhel-AppStream
Name                        Stream                          Profiles                                   Summary                                                       
perl                        5.24                            common, minimal                            Practical Extraction and Report Language                      
perl                        5.26 [d]                        minimal, default [d]                       Practical Extraction and Report Language                      

Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled

# yum module install perl:5.24
Last metadata expiration check: 0:05:19 ago on Thu 20 Dec 2018 09:16:03 AM EST.
Error: Problems in request:
broken groups or modules: perl:5.24
Modular dependency problem:

 Problem: module perl-YAML:1.24:820181214175558:8652dbeb-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - conflicting requests
  - module perl:5.26:20180618135756:9edba152-0.x86_64 conflicts with module(perl:5.24) provided by perl:5.24:820181213142604:ee766497-0.x86_64
  - module perl:5.24:820181213142604:ee766497-0.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:20180618135756:9edba152-0.x86_64
  - module freeradius:3.0:820181213135451:fbe42456-0.x86_64 requires module(perl:5.26), but none of the providers can be installed
  - module perl-YAML:1.24:820181214175558:7c757546-0.x86_64 requires module(perl:5.24), but none of the providers can be installed

dnf-4.0.9.1-1.el8.noarch
libdnf-0.22.4-1.el8.x86_64

According to the Fixed in version field this should be addressed in the libdnf version I have.

Comment 4 Jaroslav Mracek 2019-01-02 14:43:20 UTC

*** This bug has been marked as a duplicate of bug 1648839 ***


Note You need to log in before you can comment on or make changes to this bug.