Bug 165336 - Exception in thread "main" java.lang.NoClassDefFoundError: sax.Counter
Exception in thread "main" java.lang.NoClassDefFoundError: sax.Counter
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xerces-j2 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Archit Shah
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-08 01:22 EDT by han pingtian
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 15:25:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description han pingtian 2005-08-08 01:22:16 EDT
Description of problem:
I want to run the demo of xerces-j2, Counter.But it says
"Exception in thread "main" java.lang.NoClassDefFoundError: sax.Counter"

Version-Release number of selected component (if applicable):
xerces-j2-2.6.2-4jpp_5fc
xerces-j2-demo-2.6.2-4jpp_5fc
gij (GNU libgcj) version 4.0.1 20050727 (Red Hat 4.0.1-5)

How roducible:

Steps to Reproduce:
1.type "java sax.Counter"
2.
3.
  
Actual results:
Exception in thread "main" java.lang.NoClassDefFoundError: sax.Counter
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
Caused by: java.lang.ClassNotFoundException: sax.Counter not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:./,file:./],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at java.lang.ClassLoader.loadClass(java.lang.String, boolean)
(/usr/lib/libgcj.so.6.0.0)
   at java.lang.ClassLoader.loadClass(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
   at java.lang.Class.forName(java.lang.String, boolean, java.lang.ClassLoader)
(/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

Expected results:
sax.Counter run

Additional info:
Comment 1 Archit Shah 2005-08-09 15:25:44 EDT
The xerces examle can be run by specifiying the classpath. This is the expected
behavior. For example: gij -classpath
/usr/share/java/xerces-j2.jar:/usr/share/xerces-j2/xerces-j2-samples.jar
sax.Counter file:///etc/xml/docbook-simple.xml
Comment 2 han pingtian 2005-08-09 22:39:08 EDT
Thank you very much!

Note You need to log in before you can comment on or make changes to this bug.