Bug 165339 - MTR shows duplicate entries in the "route"
MTR shows duplicate entries in the "route"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mtr (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-08 04:12 EDT by Dean Earley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 02:10:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Earley 2005-08-08 04:12:53 EDT
Description of problem:
Running MTR 0.69-3 will show multiple duplicate entries on some hops (appear to 
be core routers where i have multiple routes.
It appears to do this when the 2nd (or more) ip for that hop is different to 
the first.

How reproducible:
Every time

Steps to Reproduce:
mtr zucchini.blitzed.org from my server 
or
mtr through most large isps that have multiple routes through their network
  
Actual results:
 2. aa1-
hg3.ilford.broadband.bt.net                                                 
0.0%   139   15.0  78.4  14.2 975.3 148.6
 3. aa1-
fer2G10.ilford.broadband.bt.net                                             
0.0%   139   59.5  76.5  14.6 1064. 150.9
    aa1-fer2gig3.ilford.broadband.bt.net
    aa1-fer1G10.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
 4. aa1-
nteatm2.2.ilford.broadband.bt.net                                           
0.0%   139   33.8  80.1  15.5 1027. 148.9
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
 5. 
aimless.aaisp.net.uk                                                            
0.0%   139   17.6  75.6  15.7 981.4 145.3
 6. ge-2-0-216.ipcolo1.London1.Level3.net     


Expected results:
 2. aa1-
hg3.ilford.broadband.bt.net                                                 
0.0%   139   15.0  78.4  14.2 975.3 148.6
 3. aa1-
fer2G10.ilford.broadband.bt.net                                             
0.0%   139   59.5  76.5  14.6 1064. 150.9
    aa1-fer2gig3.ilford.broadband.bt.net
    aa1-fer1G10.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
 4. aa1-
nteatm2.2.ilford.broadband.bt.net                                           
0.0%   139   33.8  80.1  15.5 1027. 148.9
    aa1-nteatm2.1.ilford.broadband.bt.net
 5. 
aimless.aaisp.net.uk                                                            
0.0%   139   17.6  75.6  15.7 981.4 145.3
 6. ge-2-0-216.ipcolo1.London1.Level3.net
Comment 1 Dean Earley 2005-08-08 04:15:45 EDT
Apologies for the bad wrapping. Here are the actualy and expected results 
without the ping times:

actual:
 2. aa1-hg3.ilford.broadband.bt.net
 3. aa1-fer2G10.ilford.broadband.bt.net
    aa1-fer2gig3.ilford.broadband.bt.net
    aa1-fer1G10.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
 4. aa1-nteatm2.2.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
 5. aimless.aaisp.net.uk
 6. ge-2-0-216.ipcolo1.London1.Level3.net

expected:
 2. aa1-hg3.ilford.broadband.bt.net
 3. aa1-fer2G10.ilford.broadband.bt.net
    aa1-fer2gig3.ilford.broadband.bt.net
    aa1-fer1G10.ilford.broadband.bt.net
    aa1-fer1G30.ilford.broadband.bt.net
 4. aa1-nteatm2.2.ilford.broadband.bt.net
    aa1-nteatm2.1.ilford.broadband.bt.net
 5. aimless.aaisp.net.uk
 6. ge-2-0-216.ipcolo1.London1.Level3.net
Comment 2 Phil Knirsch 2005-09-05 08:29:08 EDT
The problem is that internally mtr most likely sorts and remembers routers with
their ip addresses.

If a router now has more than 1 address it will treat that logically as a new
router. If the router has the same name entry in the DNS though mtr will happily
display that name twice or more, depending on how many addresses that router has
and returns to you.

Try running mtr with the option --no-dns, you shouldn't see any duplicate ip
addresses there at all.

So this is actually expected behaviour.

Read ya, Phil
Comment 3 Dean Earley 2005-09-05 13:44:09 EDT
That is what I thought at first but...

 3. aa1-fer1G10.ilford.broadband.bt.  0.0%   173   16.0  18.8  14.3 192.9  17.6
    aa1-fer1gig3.ilford.broadband.bt.net
    aa1-fer2G10.ilford.broadband.bt.net
    aa1-fer2gig3.ilford.broadband.bt.net
    aa1-fer2gig3.ilford.broadband.bt.net
    aa1-fer2G10.ilford.broadband.bt.net

Compared to:
 3. 217.47.56.33                      0.0%   175   17.8  18.7  14.3 192.9  17.5
    217.47.56.1
    217.47.56.34
    217.47.56.2
    217.47.56.2
    217.47.56.34

I pressed 'n' to see that and there is only 4 distinct IPs there.

When I tried with --no-dns, it was worse:
 3. 217.47.56.1                       0.0%    11   16.4  15.9  15.1  16.6   0.6
    217.47.56.34
    217.47.56.33
    217.47.56.33
    217.47.56.33
    217.47.56.33
    217.47.56.34

Comment 4 Phil Knirsch 2005-10-21 11:04:20 EDT
Hm, true....

Will have to look closer into it...

Read ya, Phil
Comment 5 Fedora Update System 2006-03-27 11:52:34 EST
mtr-0.71-0.FC4.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Dean Earley 2006-03-29 17:21:22 EST
I can confirm this has fixed the issue I was seeing:
 1. router.earlsoft.co.uk
 2. careless.aaisp.net.uk
 3. aimless.aaisp.net.uk
 4. 186.ge1-0.er1a.lhr4.uk.above.net
 5. so-2-2-0.cr2.lhr4.uk.above.net
 6. pos7-0.mpr2.lhr1.uk.above.net
 7. 213-152-230-99.google.net
 8. 72.14.238.246
    72.14.238.242
    72.14.238.242
    72.14.238.242
 9. 216.239.49.254
10. 216.239.48.158
    216.239.49.114
    216.239.49.114
    216.239.49.114
    216.239.48.146
    216.239.48.146
    216.239.48.146
11. 216.239.49.126
    66.249.95.164
    66.249.95.164
    216.239.59.99
    216.239.59.99
    216.239.59.99
12. 216.239.49.114
    216.239.59.99
    216.239.59.99
    216.239.59.99
    216.239.59.99
    216.239.59.99
    216.239.59.99
    216.239.59.99
13. 216.239.59.99

It is now reporting:
 1. router.earlsoft.co.uk
 2. careless.aaisp.net.uk
 3. aimless.aaisp.net.uk
 4. 186.ge1-0.er1a.lhr4.uk.above.net
 5. so-2-2-0.cr2.lhr4.uk.above.net
 6. pos7-0.mpr2.lhr1.uk.above.net
 7. 213-152-230-99.google.net
 8. 72.14.238.242
    72.14.238.246
 9. 216.239.49.254
    216.239.43.91
10. 216.239.48.158
    216.239.49.114
    216.239.48.146
11. 66.249.95.164
    216.239.49.126
    216.239.59.99
12. 216.239.59.99
    216.239.49.114

Thank you.

Note You need to log in before you can comment on or make changes to this bug.