This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165341 - KDE ignores $PATH in "ALT F2"
KDE ignores $PATH in "ALT F2"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-08 06:21 EDT by Ralf Aumueller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 14:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Aumueller 2005-08-08 06:21:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
KDE ignores $PATH in "ALT F2" when the filename is equal to a programm
with is known by KDE (because of a desktop File in /usr/share/applications).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
(Just an example with mozilla))
1. login under KDE
   echo $PATH 
2. create the following file under a directory witch is bevor /usr/bin in Your PATH with name mozilla (probably You must do that as root)
#!/bin/sh
xterm
3. chmod 755 mozilla
4. Logout -- then login again
5. Start mozilla on a command line: an xterm opens
Start mozilla with "ALT F2": the "normal" mozilla starts

  

Additional info:
Comment 1 Ngo Than 2005-08-08 14:06:22 EDT
if you use the file name as it already exists in ther /usr/share/applications,
the runCommand() function will start your application from
/usr/share/applications first. It's not a bug here.

In your case if you really want to start it from your search path, you should
activate "Use terminal" in the options menu.

Comment 2 Ralf Aumueller 2005-08-09 02:45:58 EDT
(In reply to comment #1)
> if you use the file name as it already exists in ther /usr/share/applications,
> the runCommand() function will start your application from
> /usr/share/applications first. It's not a bug here.
> 
> In your case if you really want to start it from your search path, you should
> activate "Use terminal" in the options menu.
> 
> 

Than these behavior changed from Fedora1 to Fedora4.
And if You look in the mozilla.desktop file the Exec= just start mozilla with no
path. If I name the testfile e.g. mozilla2 than the path is considered even in
the runCommand() functions. The problem ist just with programms witch have a
.desktop file.

Note You need to log in before you can comment on or make changes to this bug.