Bug 165347 - Pgdown/pgup key on Allowable Drives causes anaconda to crash
Pgdown/pgup key on Allowable Drives causes anaconda to crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: newt (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Jay Turner
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-08-08 09:11 EDT by Mike MacCana
Modified: 2015-01-07 19:10 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0309
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case for crashing on CheckboxTree size (316 bytes, text/plain)
2005-10-05 12:44 EDT, Chris Lumens
no flags Details
newt-0.52.2-pgupdown-crash.patch (1.09 KB, patch)
2006-01-17 12:46 EST, Petr Rockai
no flags Details | Diff

  None (edit)
Description Mike MacCana 2005-08-08 09:11:05 EDT
Description of problem:
When creating a new partition, using the text installer, pressing the page up on
the 'Allowable Drives' option causes anaconda to crash instantly. 

How reproducible:
Always

Steps to Reproduce:
1.Start installer in text mode
2.Create a new partition
3.Make 'Allowable drives' the active widget
4.Press pgup
Comment 1 Chris Lumens 2005-08-08 14:44:25 EDT
If you're getting a traceback, could you attach it to this bug?
Comment 2 Jeremy Katz 2005-09-21 17:05:47 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.
Comment 3 Mike MacCana 2005-09-21 19:30:43 EDT
No, I'm not getting a traceback. Just 'installer exited normally' etc. There's a
few 'File Descriptor Left' open messages in the VT.

The bug can be reproduced 100% of the time on RHEL4 U0 and is repeatedly coming
up from GLS customers.



Comment 4 Mike MacCana 2005-09-21 19:32:19 EDT
Er, 'abnormally', even.
Comment 5 Mike MacCana 2005-09-21 19:39:20 EDT
More info: PgDown just once also causes a crash.
Comment 6 Chris Lumens 2005-10-05 12:11:47 EDT
The problem here is that when the specificed height of a CheckboxTree is larger
than the length of the list of items, ct->firstItem is invalid in
checkboxtree.c:ctDraw.  Minimal reproducer is attached.
Comment 7 Chris Lumens 2005-10-05 12:44:21 EDT
Created attachment 119642 [details]
Test case for crashing on CheckboxTree size
Comment 8 Petr Rockai 2006-01-17 12:44:17 EST
The version of newt in fedora core development should be fixed now. I'll 
attach the patch fixing this issue in newt 0.52.2 shortly. 
Comment 9 Petr Rockai 2006-01-17 12:46:19 EST
Created attachment 123314 [details]
newt-0.52.2-pgupdown-crash.patch

The Fedora Core development patch to fix this issue. (Backported patch against
RHEL4 will be provided later).
Comment 10 Petr Rockai 2006-01-19 07:58:08 EST
The patch turns out to apply cleanly on RHEL4 version of newt as well, so it  
can be used unmodified. In my limited testing, it seems to work well (no 
crashes with the testcase).  
Comment 14 Bob Johnson 2006-04-11 11:44:25 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 16 Red Hat Bugzilla 2006-08-10 17:17:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0309.html

Note You need to log in before you can comment on or make changes to this bug.