Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1653508 - SELinux is preventing geoclue from 'search' accesses on the directory 1486.
Summary: SELinux is preventing geoclue from 'search' accesses on the directory 1486.
Keywords:
Status: CLOSED DUPLICATE of bug 1520446
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e6e000d78b4f6c965d3bcba8bfe...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-27 02:57 UTC by kevinafrica
Modified: 2019-01-09 17:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-09 17:28:01 UTC
Type: ---


Attachments (Terms of Use)

Description kevinafrica 2018-11-27 02:57:59 UTC
Description of problem:
SELinux is preventing geoclue from 'search' accesses on the directory 1486.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that geoclue should be allowed search access on the 1486 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'geoclue' --raw | audit2allow -M my-geoclue
# semodule -X 300 -i my-geoclue.pp

Additional Information:
Source Context                system_u:system_r:geoclue_t:s0
Target Context                system_u:system_r:unconfined_service_t:s0
Target Objects                1486 [ dir ]
Source                        geoclue
Source Path                   geoclue
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.2-42.fc29.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.19.3-300.fc29.x86_64 #1 SMP Wed
                              Nov 21 15:27:25 UTC 2018 x86_64 x86_64
Alert Count                   9
First Seen                    2018-11-11 20:10:24 PST
Last Seen                     2018-11-26 18:54:20 PST
Local ID                      8002a008-b04e-4fe4-b687-56d196d4420b

Raw Audit Messages
type=AVC msg=audit(1543287260.36:261): avc:  denied  { search } for  pid=2505 comm="geoclue" name="1486" dev="proc" ino=36014 scontext=system_u:system_r:geoclue_t:s0 tcontext=system_u:system_r:unconfined_service_t:s0 tclass=dir permissive=0


Hash: geoclue,geoclue_t,unconfined_service_t,dir,search

Version-Release number of selected component:
selinux-policy-3.14.2-42.fc29.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.6
hashmarkername: setroubleshoot
kernel:         4.19.3-300.fc29.x86_64
type:           libreport

Potential duplicate: bug 1520446

Comment 1 Lukas Vrabec 2019-01-09 17:28:01 UTC

*** This bug has been marked as a duplicate of bug 1520446 ***


Note You need to log in before you can comment on or make changes to this bug.